Skocz do zawartości


Zdjęcie

Zestaw z Chin - Quadcopter F450 z APM2.6 - relacja


  • Zaloguj się, aby dodać odpowiedź
241 odpowiedzi w tym temacie

#1 PioDabro

PioDabro
  • Modelarz
  • 263 postów
  • Age: 27
  • SkądGdańsk
  • Imię:Piotr

Napisano 15 December 2015 - 18:52

Uwaga dla tych którym nie chce się czytać całego wątku:

Po dłuższym czasie w zestawie wymieniłem bardzo dużo rzeczy, gdyż oryginalne są lekko mówiąc trudne w użytkowaniu.
Zdecydowanie polecam nie kupowanie zestawu opisywanego poniżej tylko inny, np. ten: https://www.aliexpre...2476744704.html

Jest nieco droższy, ale są w nim dodatkowe elementy które i tak trzeba kupić oddzielnie  (nogi, stojak do GPS, PowerModule itp.)
Dodatkowo są sporo lepsze podzespoły: silniki (mają inne piasty i nakrętki CW i CCW), rama (sztywniejsze i lepiej wykonane ramiona)

Pierwsze co wymieniłem to były właśnie silniki, w tym zestawie poniżej są piasty zaciskowe które niestety odkręcają się w locie.
Dodatkowo polecam nie lutować złączek bananowych tylko bezpośrednio ESC do silnika zlutować. Unikniecie niepotrzebnych kretów :)

 

 

 

Witam,
 
ostatnie kilka dni spędziłem na budowie swojego pierwszego quadro.
Pierwszym krokiem było zamówienie aparatury i zestawu z Chin.
Aparaturę zakupiłem za 40$ podczas promocji 11.11 na Aliexpress.
Zestaw części nieco później za 80$.
 
W skład zestawu wchodzą następujące części:

(link do zestawu: http://www.aliexpres...402430079.html)
 
Rama F450 (kopia tej od DJI ale dość dobrze wykonana z jedną małą wadą ale o tym później).
Zestaw silników 4 x A2212/13T  1000KV -> Chińskie ale działają :) Razem z silnikami byłu mocowania na śmigła.
Dwie pary śmigieł nylonowych 1045
12 par złączek "bananowych"
Moduł APM2.6 w obudowie (razem z nim przewód do telemetrii i drugi wyglądający jak do PowerModule z tym, że wtyczki za wąskie)
Moduł GPS uBlox M6 z kompasem w obudowie
Trochę koszulek termokurczliwych
Śrubki do ramy (kilka nadmiarowych)
Śrubki do silników (też trochę nadmiarowych)
Złącze T-Dean
2 przewody silikonowe 10cm (czarny i czerwony)
Dodatkowa płytka rozdziału prądu(poza tą w ramie)
4 sztuki ESC Hobbypower 30A
 
Ogólnie wszystko to co na zdjęciu:
photo14.jpg


Pierwsze czynności z nowo nabytym zestawem polegały na przykręceniu ramion do dolnej części podstawy.
I tu pojawił się mały problem z jakością ramion. W miejscach gdzie wkręca się śrubki są co prawda tulejki metalowe, ale śrubka jest dość długa.
W samą tulejkę wkręcają się dobrze natomiast gdy wkręcamy dalej część śrubek bardzo ciężko szła.
Dziurki te są trochę za wąskie, ale wkręcając powoli i z wyczuciem udało się poskręcać model i wszystko pasuje.
Jest za to zaleta ciasno siedzących śrub: w locie się na pewno od drgań się nie odkręcą :)
Podczas wkręcania zniszczyłem tylko 1 śrubkę (uszkodziłem gniazdo na imbusa). Na szczęście w zestawie była nadmiarowa ilość.
 
Kolejny krok to montaż silników. Tutaj już bez niespodzianek.
Wszystko ładnie pasuje, śrubki odpowiedniej długości, jedynie od siebie dołożyłem podkładki pod śrubki (goły plastik pod spodem).
 
Następnie przymocowałem ESC. ESC zamocowałem od góry, będą się lepiej chłodzić.
ESC standardowo zamocowane na "trytytki" ;)
Skróciłem nieco przewody od ESC i przylutowałem konektorki.
Nie chciałem ich skracać zbyt mocno więc skróciłem także przewody od silników.
Następnym raze skrócę tylko te od ESC ;) Przewody od silników to druciki w emalii w koszulce. Ciężko się to lutuje.
Natomiast poradziłem sobie z tym podgrzewająć lutownicą odizolowane końcówki przewodów (320 stopni - emalia się wypaliła) na końcu pocynowując je.
W efekcie miałem skrócone przewody, ale kosztowało to dodatkową pracę.
photo27.jpg


//Ciąg dalszy 1:

Po montażu ESC i silników zabrałem się za lutowanie płytki rozdzielającej prąd.
Użyłem oczywiście tej dodatkowej, skoro jest. Do płytki przylutowałem przewodami 4mm^2 złącze na baterię T-Dean.
Po bokach przylutowałem przewody od ESC.

Po polutowaniu ESC i zasilania zamocowałem górną płytę ramy i skręciłem. Do górnej płyty ramy od dołu przykręciłem tą płytkę prądową.
Miała akurat 4 otwory w tych samych miejscach co fabryczne w górnej płytce ramy. Nie musiałem nawet stosować tulejek dystansowych bo płytka ładnie oparła się rogami o plastikowe elementy ramion.
Płytkę dokręciłem śrubkami M3 i nakrętkami samokontrującymi (tymi z plastikowym kołnierzem) aby się od wibracji nie poluzowała.
Tutaj na foto widać wspomnianą płytkę, niestety nie chcę rozkręcać całości by zrobić lepsze zdjęcie.
photo26.jpg

Początkowo chciałem zamocować kontroler na dolnej płycie ramy, a baterię mocować u góry, ale po przymierzeniu okazało się, że łatwiej będzie zrobić na odwrót.
Głównie ze względu na wystające od góry złącza odbiornika RC i ESC.

Kontroler do górnej płyty przykleiłem gąbkową taśmą dwustronną.
Obok kontrolera w zielonej koszulce termokurczliwej jest przetworniczka step-down z ustawionym napięciem wyjściowym 5V. Służy jako BEC do zasilania APM'a.
Odibiornik prąd pobiera z APM'a. BEC'a podłączyłem do wolnych pinów od ESC (zworka JP1 w APM założona).
ESC mają wyjęte środkowe piny od ich BEC'ów. Używam oddzielnego, własnego.

Odbiornik RC zamontowałem na wystającej do przodu koptera części dolnej płyty ramy, także za pomocą piankowej dwustronnej taśmy.

Fotka:
photo28.jpg


//Ciąg dalszy 2:

Mając już umocowane wszystko na miejscu, podłączyłem ze sobą wszystkie moduły.
Czas na kalibrację. Po podłączeniu do USB i wgraniu firmware'u wykonałem kalibrację akcelerometru.
Następnie czas na kompas, tutaj też bez większych problemów się skalibrował.
Następnie radio, za pierwszym razem skalibrowałem je tak jak było ustawione. Później nieco pozmieniałem w samym radiu i kalibrowałem je jeszcze raz, ale o tym za chwilę.
Na koniec czas na ESC. Tutaj już bez użycia USB.
Odpiąłem od komputera i skalibrowałem metodą wszystkie na raz:
W radiu ustawiamy throttle na max, podłączamy na chwilę zasilanie (tak z 2s), rozłączamy i podłączamy ponownie.
Następnie po piknięciu ESCów throttle w dół. ESC po raz kolejny zapikały. Szybki test unosząc throttle w górę, działa.

Jak już wszystko skalibrowałem, czas na założenie śmigieł.
Założyłem śmigła i przywiązałem model do stolika kawowego (żeby mi w mieszkaniu gdzies nie pofrunął ;) )
photo18.jpg
Pierwszy test ze śmigłami szybko wykazał duże wibracje. Po zdjęciu śmigieł na druciku sprawdziłem ich wyważenie: dwa śmigła w porządku, a dwa totalnie do bani.
Jedno z nich udało mi się wyważyć podszlifowując spodnią stronę cięższej łopatki. Drugie wymagało niestety naklejenia tasiemki.
Użyłem takiej bardzo mocnej żelowej dwustronnej tasiemki montażowej. Tasiemki przykleiłem od góry "po zawietrznej".
Dodatkowo 1 z pozostałych dwóch wymagało lekkiego wyważenia ośki.
Na ogół polecam od razu sprawdzić śmigła zanim jeszcze je zamontujemy.
Foto "wyważonego" śmigła:
photo25.jpg

Po wyważeniu śmigieł wibracje są zdecydowanie mniejsze. Jak dojedzie do mnie z Chin wyważarka magentyczna to wyważe je jeszcze dokładniej.
Jeżeli ktoś lata z kamerą to wyważenie śmigieł jest najważniejszą czynnością jaką trzeba wykonać w celu pozbycia się jello.

 

//Ciąg dalszy 3

 

Po kilku testach i kombinacjach przyszedł czas na małe zmiany w ułożeniu elementów.

W międzyczasie przyszły nogi do kopter'a więc przeniosłem baterię pod spód dolnej płytki.

Nabyłem także trochę samoprzylepnych rzepów. Odbiornik zamiast piankowej taśmy jest teraz przymocowany na rzec i nieco schowany między górną i dolną płytkę ramy.

Dodałem także podwieszoną pod spodem kamerkę z przodu. Kamerka wisi na rzepie oraz zabezpieczona jest trytką. Ustawiona lekko parząc w dół.

Przesunięta nieco do tyłu bateria równoważy kamerkę.

Czekam jeszcze na stojaczek pod GPS. Ważny element do zwieńczenia całości ;)

 

Ważną rzeczą jest też drobna zmiana napięcia oddawanego przez wspomnianą wcześniej przetworniczkę.

Ponieważ po drodze między pinami Outputs a zasilaniem samego APM'a jest dioda która wywołuje mały spadek napięcia.

POwerRails.png

Zasilając APM  z założoną zworką JP1 i z pinów od ESC napięcie warto nieco podnieść. Do wartości 5.37V (Taką wartość nominalną podają tutaj: http://copter.ardupi...jp1_installed).

 

Dlaczego tak? Zmierzyłem sobie napięcie jakie zasila odbiornik. Wynosiło 4.49V co jest minimalnie poniżej dolnej granicy napięć odbiornika.

Do tego łatwo wywnioskować ża APM miał takie samo napięce. Dodając to tego zakłócenia od silników i ESC mogło to powodować resety i inne dziwne zachowania APM'a i odbiornika.

Podniosłem napięcie do 5.3V i na odbiorniku mam już 4,87V co jest już całkiem akceptowalną wartością.

Pamiętajcie jednak żeby nie przesadzić. Wszystko dokładniej opisane jest tu: http://copter.ardupi...s_jp1_installed

 

Na obecną chwilę wygląda to tak:

photo35.jpg

 

 

Post będę rozwijał dalej innymi słowy mówiąć "Ciąg dalszy nastąpi".
Powyższy opis uzupełnię zdjęciami jak je porobię :)
 
Wybaczcie brak zdjęć z budowy, ale tak mnie robota pochłonęła, że o tym zapomniałem :)
 
 
Na koniec kilka zdjęć już zmontowanego quadrocopter'a.

photo17.jpg

photo24.jpg


  • 1

#2 okruszek

okruszek
  • Modelarz
  • 185 postów
  • Age: 30
  • GG:
  • SkądSzczecin
  • Imię:Mirek

Napisano 15 December 2015 - 19:06

Witaj.

Od dłuższego czasu przyglądam się temu ARF F450.

Cena fajna, ale jak ten APM 2.6 się sprawuje.

Jak na pierwszy model, to dość fajny zestaw za nieduże pieniążki.

 

Jakim LiPo napędzasz F450 ;]


  • 0

#3 PioDabro

PioDabro
  • Modelarz
  • 263 postów
  • Age: 27
  • SkądGdańsk
  • Imię:Piotr

Napisano 15 December 2015 - 21:32

Zestaw od Chińczyka kupiłem ten:
http://www.aliexpres...2402430079.html

APM jak APM - działa ;)
Jedyne co obudowa trochę słabo spasowana (troszkę trudniej wpiąć ESC i odbiornik w piny, ale za to lepiej się trzymają :) )
Ale za te pieniądze jakość bardzo dobra.
Jeszcze nie zdążyłem nim polatać, jedynie zrobiłem test na uwięzi (patrz foto u góry).

Pakiet do niego kupiłem w Polsce - Redox 3S 3600mAh 20C.
Teraz kombinuję by zakupić drugi np. Turnigy 5.0 z HK.
Ale 1 sztuka z przesyłką wychodzi tyle samo co w PL. Więc na razie odpada. Po drugie po co mi na zimę 2 sztuki ? ;)
  • 0

#4 Mitar

Mitar
  • Modelarz
  • 386 postów
  • Age: 35
  • SkądGliwice
  • Imię:Michał

Napisano 16 December 2015 - 09:16

ESC możesz spokojnie dać pod ramiona ,nie trzeba aż takiego chłodzenia a będzie estetyczniej.

 

Docelowo baterię najlepiej dać na sam dół na rzep i opaskę a w środek pchać wszystko co brzydkie :), Oczywiście do tego jakieś nogi, mogą być te zwykłe białe za parę $ z Chin.

 

Dokup sobie więcej śmigieł i najlepiej zapasową ramę, nie są drogie a zaoszczędzi ci to dużo czasu (jeśli zamawiasz z Chin) w razie kreta . Wiem co mówię :P https://www.youtube....h?v=jLer-EaelEA

 

APM jest fajnym sterownikiem ale trzeba go "przygotować" odpowiednio (gąbka na baro, odpowiednie ustawienie kompasu nie wg strzałki, uaktywnienie failsafe itp)

 

Co do baterii to ja zamówiłem ostatnio 4 pakiety 5200 3S Multistara z HK , w sumie mam teraz razem 6 ,ale chyba przesadziłem i z chęcią 1-2 sztuki odsprzedam.


  • 1

#5 filek

filek
  • Modelarz
  • 99 postów
  • Age: 40
  • SkądWarszawa Włochy
  • Imię:Paweł

Napisano 16 December 2015 - 09:55

Przymierzam się do tego zestawu, Twoja relacja mnie przekonała :)


  • 0

#6 PioDabro

PioDabro
  • Modelarz
  • 263 postów
  • Age: 27
  • SkądGdańsk
  • Imię:Piotr

Napisano 16 December 2015 - 10:39

Mitar,

bateria jak pisałem jest na dolnej płytce w środku, na rzep.
Mi odpowiada, tym bardziej że jest chroniona w przypadku kreta.

Te Multistary to niby tanie i lekkie ale jakoś mało wydajne. Tylko 10C. Przy 5200 mAh daje max 52A. Moja 3600 mAh daje 72A :)
Jak z ich pojemnością? Rzeczywiście mają te 5200mAh??
Moje silniczki biorą 12A max każdy co daje 48A już na same silniki. Owszem pewnie nie będę używał ich na max wydajności, ale warto mieć zapas :)

Co do dodatków to dodatkowo z Chin do mnie leci:

Stojaczek pod GPS'a (2,44$)
Nogi w kolorze czarnym (2,39$)
5 par zapasowych śmigieł (4,98$)
Wyważarka magnetyczna do śmigiel (w tej chwili wyważone na drucie, zawsze lepiej niż latać na totalnie niewyważonych). (3,42$)

Także o nogach i śmigłach już pomyślałem wcześniej. Oby śmigła nie były potrzebne :)
  • 0

#7 Mitar

Mitar
  • Modelarz
  • 386 postów
  • Age: 35
  • SkądGliwice
  • Imię:Michał

Napisano 16 December 2015 - 11:04

Ale mi chodziło o sam dół w sensie pod dolną płytką :), jeśli będziesz miał nóżki to są małe szanse ,że coś się jej stanie a zyskasz miejsce w środku.

 

Jesteś pewny, że te silniki pobierają 48A ? bo moje(2212 920kv) wg danych też niby podobnie pobierają a w praktyce średnio 25A, max 35A (oczywiście chodzi o 4 sztuki).

Co do Multistarów to są to tanie lekkie baterie do właśnie takich "budżetowych" quadr. Do czegoś "większego" to już coś z dużym C i 4S.

Zgodnie z dokumentacją daje 52A a max do 104A (20C do 10s)

Ponieważ nie lata się do odcięcia więc ciężko powiedzieć czy równo 5200 ale na pewno bardzo blisko.

 

Co do GPS to tu też pomyśl o jakimś zabezpieczeniu (tym bardziej na stojaku), bo mi po jednym krecie jak quadra walnęła do góry nogami poszła cała antena ceramiczna, GPS do kosza :/.

 

Teraz mam kupiony (za 1$ w promocji czarnego piątku) taki stojaczek http://www.ebay.com/...6-/351423509056

Te zabezpieczenie przed zakłóceniami pewnie to ściema ale te boczne ścianki przyjmą na klatę uderzenie. A wolę stracić taki mount niż dużo droższy GPS , tym bardziej że latam teraz na http://www.aliexpres...2245591458.html

 

A jeszcze jedno co do stojaczków na anteny, lepiej mieć te na 1 śrubkę , mają mniej stabilne mocowanie ale jak walniesz to nie wyrwie ci pół ramy :P


  • 0

#8 qpa

qpa
  • Administrator
  • 2960 postów
  • Age: 28
  • GG:
  • SkądLublin/Wrocław
  • Imię:Kuba

Napisano 16 December 2015 - 11:32

 

 

APM jest fajnym sterownikiem ale trzeba go "przygotować" odpowiednio (gąbka na baro, odpowiednie ustawienie kompasu nie wg strzałki, uaktywnienie failsafe itp)

 

 

Możesz coś więcej na ten temat?

 

 

ps. Piotr, możesz wrzucić zdjęcia na serwer forum? 


  • 0

#9 Mitar

Mitar
  • Modelarz
  • 386 postów
  • Age: 35
  • SkądGliwice
  • Imię:Michał

Napisano 16 December 2015 - 12:21

Możesz coś więcej na ten temat?

 

Pisałem już o tym  w paru miejscach ale nie jestem zwolennikiem odsyłania ludzi do innych tematów więc napiszę tu zbiorczo to na co należało by zwrócić uwagę:

 

1) Zasilanie - APM jest bardzo wrażliwy na zmiany napięcia a także na jego wartość, tu największy problem może sprawić kiepskiej jakości BEC, bo przy napięciu poniżej 4.6V może złapać tak zwanego browouta czyli coś w stylu resetu, a tego nie chcecie :). powyżej 5.5V może się wyjrajać. To samo się tyczy zmian , jeśli sa duże zmiany napięcia też może złapać zwieche/reseta.

Dlatego osobiście polecam używać power module z APM tylko do pomiaru a zasilać z jakiegoś dobrego BECa 5.3V (ja mam taki http://www.hobbyking...UBEC_3A_5v.html

 

2) Gąbka na barometr - nie bedę się wdawał w szczegóły bo polegnę na teorii ale chodzi o to, że obudowa APM nie jest szczelna, i przy wietrzyku albo locie w środku... wieje :) Barometr tego nie lubi i zaczyna świrować (raz mi się tak zdarzyło i źle podawał wysokość), dlatego stosuje się gąbkę.

Ja mam zrobione to mniej więcej tak http://s18.postimg.o...22_01_10_04.jpg , ale każdy sposób jest dobry.

 

3) Antena GPS i kierunek - większość anten GPS które widziałem ma źle podaną strzałkę na obudowie i zakładając wg tej strzałki osiągniemy taki efekt ,że przy loiter zacznie nam quadra robić coraz większe okregi uciekając do Chin (źle podawany kierunek). Najlepiej podpiąć quadrę do kompa/laptopa z netem ,zabrać sprzęt na powietrze (ja robiłem to na balkonie) i kręcić już zamontowaną antenką aby te linie które tam pokazuje zbiegały się z charakterystycznym obiektem (u mnie był to mały budynek) wtedy jest pewność że dobrze mamy ustawioną antenkę GPS (pod względem kierunku).

Warto przed każdym lotem sobie to sprawdzać bo RTL przy failsafe może zamiast do domu zaprowadzić quadrę do lokalizacji "producenta" ;)

Aha uwaga! Odsuwamy quadrę od kompa i innych elektrczynych wynalazków bo może zaburzyć wskazania.

 

4) Failsafe - Jeśli nie macie w nadajniku możliwości obsługi failsafe to możecie mieć ten sam problem co ja na początku.

Na czym polega problem? No więc ja mam aparaturę Turnigy 9x ze stockowym nadajnikiem i odbiornikiem.

Gdy gubił zasięg albo wyłączałem aparaturę sygnał w APM się nie zmieniał . A failsafe w APM polega na tym że ustawia się wartość sygnału dla Failsafe (przeważnie koło 900).

Znalażlem rozwiązanie w filmiku https://www.youtube.com/watch?v=HtaXna9KsS0&feature=youtu.be

W skrócie polega to na tym aby zaktualizować encoder w APM.

Możliwe że na waszych APM będzie to zrobione.

Po tym zabiegu przy braku połaczeniu z aparaturą wskakuwał mi sygnał w APM na 925.

Inna ma się sprawa z nadajnikiem/odbiornikiem FrSky (taki mam teraz) tam nie ma z tym problemu bo dailsafe się ustawia bezpośrednio na nich i failsafe w APM działa od strzału.

 

5) Wibracje - APM jak i każdy sterownik nie lubi wibracji, więc jeśli w waszym zestawie nie ma podkładki antywibracyjnej, polecam nabyć, tym bardziej że sporo tanich silniczków to prawdziwe szejkery :D

 

Na razie tyle pamiętam, reszta to raczej kwestia ustawień, ale APM w konfiguracji raczej dobrze prowadzi za nos.

 

Na koniec kilka moich filmików jeśli ktoś nie widział , można zobaczyć jak to wygląda w praniu:

1) Prezentacja: https://www.youtube....h?v=3yAtvgRtse0

2) Loiter: https://www.youtube....h?v=J1t8payInAI

3) Test prędkości: https://www.youtube....h?v=JSVwYnciAwU

4) Test Telemetrii (misje): https://www.youtube....h?v=MPbKmL6j4oc

5) Test taniego gimbala: https://www.youtube....h?v=IERERP7PRPM + filmik z niego: https://www.youtube....h?v=gLO-JrNKYRg


  • 0

#10 PioDabro

PioDabro
  • Modelarz
  • 263 postów
  • Age: 27
  • SkądGdańsk
  • Imię:Piotr

Napisano 16 December 2015 - 12:48

1. Prawda, dlatego właśnie zastosowałem oddzielną regulowaną przetworniczkę na LM2596. Ustawiłem na niej napięcie = 5V, ale nie problem troszkę podnieść do 5.3V ;)
Przetworniczka ma wydajność do 3A, a zasila tylko APM, GPS i odbiornik, zatem mi prądu nie powinno zabraknąć. Przetworniczkę zatopiłem w koszulce termokurczliwej więc jestem pewien, ze nastawy jej same się nie zmienią.
Można też dla pewności zamiast potencometru wieloobrotowego wlutować odpowiednie rezystory.

2. Na stronie Ardupilota jest to wyraźnie opisane. Barometr poza hulającym wiatrem nie lubi też zmian światła, dlatego warto by gąbeczka była w ciemnych kolorach.

3. W sumie o tym nie pomyślałem, że GPS musi też być ustawiony w odpowiednim kierunku.
Tutaj też trzeba zwrócić uwagę, że APM2.6 nie ma kompasu sam w sobie, tylko kompas jest razem z GPS'em. Wcześniejsza wersja miała tez kompas zintegrowany.
Na moim GPSie nie ma żadnych strzałek itp. Chyba zerknę do środka może na płytce coś namazali ;)

4. Failsafe w przypadku aparatury FlySky FS-i6 jest dość problematyczne bo można jedynie ustawić sygnał od 0% do 100%. Gdzie 0% to około 1000 PWM.
Za to w bieżącej wersji ArduCopter'a można zmienić poziom zadziałania FS. Ja temat rozwiązałem w ten sposób, że w aparaturze ustawiłem failsafe na 0% i ograniczyłem z dołu throttle o 10%.
Potem ponownie skalibrowałem RC w APM.
Dzięki temu podniosłem trochę minimalną wartość w throttle do 1050 PWM, a wyłączenie nadajnika powoduje przeskok do 1000 PWM :) w APM ustawiłem próg failsafe na 1025.
Działa poprawnie ;)
Kosztem takiego rozwiązania jest zmniejszenie rozdzielczości sterowania gazem (zakres od 1000 do 2000 zmienia się na 1050 do 2000), ale raczej jest to niezauważalna zmiana.

5. Wibracje: u mnie APM zamocowany jest na kilku warstwach gąbkowej taśmy montażowej. Powinno załatwić sprawę.


  • 0

#11 Mitar

Mitar
  • Modelarz
  • 386 postów
  • Age: 35
  • SkądGliwice
  • Imię:Michał

Napisano 16 December 2015 - 12:55

Tu jeszcze do punktu 3 bo zapomniałem, orientacja kierunku nie jest mierzona tylko ustawieniem anteny, tylko ustawieniem anteny oraz ustawieniem kierunku APM względem anteny (mimo ,że ta wersja APM nie ma kompasu)

Zróbcie sobie taki eksperyment, ustawcie antenę w 1 pozycji a zacznijcie kręcić samym APM i patrzcie na kierunek w MP :)


  • 1

#12 PioDabro

PioDabro
  • Modelarz
  • 263 postów
  • Age: 27
  • SkądGdańsk
  • Imię:Piotr

Napisano 18 December 2015 - 11:04

Tu jeszcze do punktu 3 bo zapomniałem, orientacja kierunku nie jest mierzona tylko ustawieniem anteny, tylko ustawieniem anteny oraz ustawieniem kierunku APM względem anteny (mimo ,że ta wersja APM nie ma kompasu)
Zróbcie sobie taki eksperyment, ustawcie antenę w 1 pozycji a zacznijcie kręcić samym APM i patrzcie na kierunek w MP :)

 
 
Zrobiłem mały research.
Na obudowie mojego GPS'a nie ma żadnej strzałki itd...
Po rozkręceniu dopiero na płytce widoczna jest strzałka.
Obok niej znajduje się też sam kompas.
Zgodnie z notą katalogową kierunki jego są następujące:
photo30.png
(kółko z kropką w środku oznacza, że oś Z jest skierowana do góry)
 
Na zdjęciu poniżej płytka GPS z magnetometrem.
photo34.jpg
(naniosłem tutaj osie z noty katalogowej)
 
Jest to widok od spodu płytki (po drugiej stronie jest antena GPS).
Co za tym idzie nasz magnetometr jest obrócony o 180 stopni wokół osi Y.
 
Czyli patrząc od góry na nasz cały moduł GPS osie wyglądają tak:
photo29.jpg
(kółko z X w środku oznacza, że oś Z jest skierowana do dołu)
Ta dodatkowa strzałka pokazuje kierunek zaznaczony na płytce.
 
Teraz trzeba to porównać np. z APM2.5 który ma oryginalnie akcelerometr na płytce. Dzięki temu będziemy wiedzieli jaką orientację ustawić w naszym APM, i jak umiejscowić antenę GPS.
Jak znajdę dokładną informację to dopiszę.
 
PS. W oczekiwaniu na stojaczek pod GPS zrobiłem sobie tymczasowy z pręta gwintowanego M3 i masy dwuskładnikowej. Niestety nie był to dobry pomysł: stal zaburza działanie magnetometru. Nie róbcie tego w domu :)
Stojaczki powinny być z aluminium i tym podobnych metali (niemagnetycznych).
  • 0

#13 Mitar

Mitar
  • Modelarz
  • 386 postów
  • Age: 35
  • SkądGliwice
  • Imię:Michał

Napisano 18 December 2015 - 11:13

Nie na wszystkich obudowach są strzałki , ale jak już są to w 99% źle. Chyba że strzałki są dobrze ale przy konkretnych ustawieniach w APM. Tyle że jakby to było równe 45 stopni to bym zrozumiał a u mnie odchyłka była o ~35 stopni.


  • 0

#14 PioDabro

PioDabro
  • Modelarz
  • 263 postów
  • Age: 27
  • SkądGdańsk
  • Imię:Piotr

Napisano 18 December 2015 - 11:55

Nie na wszystkich obudowach są strzałki , ale jak już są to w 99% źle. Chyba że strzałki są dobrze ale przy konkretnych ustawieniach w APM. Tyle że jakby to było równe 45 stopni to bym zrozumiał a u mnie odchyłka była o ~35 stopni.


APM jak ustawiasz zewnętrzny kompas ma domyślnie ROLL 180 stopni ustawiane (to by się zgadzało, bo obracasz wokół Y - układ do góry nogami).

Najlepiej patrzeć na ułożenie samego układu magnetometru (ma oznaczenie L883) i względem niego ustawić antenkę.
  • 0

#15 PioDabro

PioDabro
  • Modelarz
  • 263 postów
  • Age: 27
  • SkądGdańsk
  • Imię:Piotr

Napisano 18 December 2015 - 15:24

Quadcopter odbył dziś swój dziewiczy lot.
Niestety jakieś problemy miał. Wznosił się tylko w trybie Stabilize. Po przełączeniu w AltHold od razu przełączał się w Land.
Lądowanie też mu coś nie wychodziło, zaczęło go znosić i pod koniec troszku orał śmigłami, na szczęście nic im się nie stało.
Na szczęście udało mi się go przełączyć z Land na stabilize i go opanować.
Na AltHold nawet nie dał się uzbroić, tzn. uzbrajał się i zaraz rozbrajał.
Zachowanie miał takie jakby mu FailSafe zadziałało. Tylko w sumie nie za bardzo wiem dlaczego.
FS od baterii wyłączony był, jedyny włączony był od nadajnika, ale nadajnik był ok.
Informacji dostarczył mi Tower(coś ala Droid planner, tylko od 3DR) w telefonie (połączony przez Bluetooth do telemetrii).

Pierwsze co zrobiłem po powrocie to czysty firmware wgrałem.
Czas go pokonfigurować od 0 bo w międzyczasie mogłem coś nagmerać.
Skoro na AltHold nie chciał polatać, to tym bardziej nie miało sensu Loiter itd...



Co do kompasu, porównałem położenie jego z położeniem tego z APM2.5 i wychodzi na to, że kabelek to jest tył anteny.
W ustawieniach kompasu trzeba ustawić ROTATION_ROLL_180. Ponieważ względem normalnego położenia jest obrócony do góry nogami w kierunku ROLL.
  • 0

#16 Mitar

Mitar
  • Modelarz
  • 386 postów
  • Age: 35
  • SkądGliwice
  • Imię:Michał

Napisano 18 December 2015 - 15:30

Jak masz jeszcze log z tego lotu to zapodaj to się sprawdzi co było nie tak.

Ogólnie polecam ci opanowanie odczytu logów i ich interpretacji, ja z logów wyłapałem 90% swoich problemów.


  • 0

#17 PioDabro

PioDabro
  • Modelarz
  • 263 postów
  • Age: 27
  • SkądGdańsk
  • Imię:Piotr

Napisano 20 December 2015 - 11:48

Z jednego loga wylapalem zakłócenia na RC. Uruchamiało to FS od RC.
Mam tylko logi z telefonu. Pospieszyłem się trochę z resetem APM i tam niestety nic nie zostało. Ale z tych z telefonu ładnie widać alarmy.

Prawdopodobnie zakłócenia RC - Bluetooth
Trzeba zapolować na jakiś telemetry na 443MHz

Wytaptapane
  • 0

#18 qpa

qpa
  • Administrator
  • 2960 postów
  • Age: 28
  • GG:
  • SkądLublin/Wrocław
  • Imię:Kuba

Napisano 28 December 2015 - 10:19

Orientujecie się jakieś wielkości są śruby skręcające ramę? Długość, średnica oraz skok? 


  • 0

#19 PioDabro

PioDabro
  • Modelarz
  • 263 postów
  • Age: 27
  • SkądGdańsk
  • Imię:Piotr

Napisano 28 December 2015 - 13:20

Z tego co się orientuję to są to M2.5×5 o standardowym skoku

 

Tu manual od oryginału: http://www.pelikanda...ual_v1.8_en.pdf

Chińskie się zbytnio nie różnią poza samym wykonaniem i elektroniką.


  • 0

#20 qpa

qpa
  • Administrator
  • 2960 postów
  • Age: 28
  • GG:
  • SkądLublin/Wrocław
  • Imię:Kuba

Napisano 28 December 2015 - 13:47

Dzięki, zamówiłem sobie gwintownik na wszelki wypadek, bo czytałem w kilku miejscach że czasami nie da się dokręcić tych śrub :) 


  • 0


Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych