Skocz do zawartości


Zdjęcie

Jeszcze tańszy odbiornik LRS 16CH.


  • Zaloguj się, aby dodać odpowiedź
43 odpowiedzi w tym temacie

#21 maxiiii

maxiiii
  • Modelarz
  • 1506 postów
  • Age: 50
  • SkądSchwerin
  • Imię:Marek

Napisano 18 styczeń 2018 - 08:45

Kondensator jest podłączony tylko zapobiegawczo. Ze względu na różne rodzaje i jakość zasilania ma za zadanie obcinać szpilki i podtrzymywać zasilanie na odpowiednim poziomie w przypadku krótkotrwałego obniżenia napięcia.

 

poniżej zamieszczam schemat i opis dodatkowych podłączeń wyjść. W tym przypadku może być ich osiem.

 

Odbiornik  z modułem rfm23bp o mocy 1W podłącza się identycznie. jak z z innymi, wyjścia są takie same i kompatybilne. Różnią się tylko napięciem zasilania. (3,6V i 6V)

Na zdjęciu pokazałem odbiornik 1W w porównaniu wielkością do odbiornika 2,4GHz.

 

Załączone miniatury

  • openlrsHW5schemat.JPG
  • IMG_20180118_083531.jpg

  • 0

#22 GośćRomanX_*

GośćRomanX_*
  • Guests

Napisano 18 styczeń 2018 - 13:45

dzięki , ale coś mi się nie zgadza

1.nie ma buzzera i przycisku bindowania

2.ostatnie twoje zdanie powinno brzmieć raczej :

Na zdjęciu pokazałem odbiornik  nadajnik 1W w porównaniu wielkością do odbiornika 2,4GHz.

a na schemacie jest i tak 100mW 

3.na zdjęciu w lewym górnym rogu mamy wyprowadzenia PWM opisane, tylko że nie potrafię zlokalizować padów na arduino

A4, A5 dla sygnału PWM 2 i 4

 

pwm 1 - 9

pwm 2 - A4

pwm 3 - 3

pwm 4 - A5

pwm 5 - A0

pwm 6 - A1

 

sd0 i sdI to są te dodatkowe 2 wejścia ? na potencjometry od gimbala ?


  • 0

#23 maxiiii

maxiiii
  • Modelarz
  • 1506 postów
  • Age: 50
  • SkądSchwerin
  • Imię:Marek

Napisano 18 styczeń 2018 - 14:18

Napisałem odbiornik i jest to prawidłowy wpis.

Odbiorniki też mogą być nadajnikami i odwrotnie.:) Do odbiornika dodajemy tylko buzer i switcha do bindowania lub jak w oprogramowaniu podamy kod bindowania to nie będzie potrzebny ani buzzer ani switch.

Schemat podałem do 100mw i też jest prawidłowy a jak zmienimy moduł na 1W to już nie będzie 100mW a tylko 1wat.:)

 

dzięki , ale coś mi się nie zgadza

1.nie ma buzzera i przycisku bindowania

2.ostatnie twoje zdanie powinno brzmieć raczej :

Na zdjęciu pokazałem odbiornik  nadajnik 1W w porównaniu wielkością do odbiornika 2,4GHz.

a na schemacie jest i tak 100mW 

3.na zdjęciu w lewym górnym rogu mamy wyprowadzenia PWM opisane, tylko że nie potrafię zlokalizować padów na arduino

A4, A5 dla sygnału PWM 2 i 4

 

pwm 1 - 9

pwm 2 - A4

pwm 3 - 3

pwm 4 - A5

pwm 5 - A0

pwm 6 - A1

 

sd0 i sdI to są te dodatkowe 2 wejścia ? na potencjometry od gimbala ?

 

 

Nie myl aparatury z linkiem.

A4 i A5 to te 2 dodatkowe pady. W tym przypadku nieopisane ale ze względu na różnorodność arduino pro mini mogą występować w różnych miejscach.


  • 0

#24 GośćRomanX_*

GośćRomanX_*
  • Guests

Napisano 18 styczeń 2018 - 15:50

no trochę mi się jeszcze niektóre rzeczy mylą 

a załóżmy, że skorzystam z tego 3 pinowego wyjścia sygnału ppm

to mogę go tylko do kontrolera lotu podłączyć i z kontrolera są dopiero wyprowadzenia 

na serwa i esc - tak ?

a żeby od razu z takiego odbiornika podpiąć serwo i regulator to się nie da ?

to jak to zrobić / połączyć ? bo chciałbym po jeziorze na dużym zasięgu popływać łódką


  • 0

#25 maxiiii

maxiiii
  • Modelarz
  • 1506 postów
  • Age: 50
  • SkądSchwerin
  • Imię:Marek

Napisano 18 styczeń 2018 - 16:09

Każdy pin na wyjściu może być zdefiniowany prawie na dowolny sposób jako dowolny kanał, przełącznik wyjście analogowe i jeszcze kilka innych których nawet nie znam:)


  • 0

#26 rah66

rah66
  • Modelarz
  • 393 postów
  • Age: 39
  • SkądŻyrardów
  • Imię:Areg

Napisano 23 styczeń 2018 - 01:20

Narysowałem schemat blokowy. Mam nadzieję, że da się go zrozumieć :)

45447ff21b0ddf6d.jpg

a system jednoantenowy? czyli nadajnik + telemetria + wideo, podpięte do jednego linka 2.4ghz, 433mhz, 1.2ghz lub innego?


  • 0

#27 maxiiii

maxiiii
  • Modelarz
  • 1506 postów
  • Age: 50
  • SkądSchwerin
  • Imię:Marek

Napisano 23 styczeń 2018 - 08:41

Takie rzeczy to tylko w erze  (lub fantomie:)


  • 0

#28 Rumcajs

Rumcajs
  • Modelarz
  • 22 postów
  • Age: 51
  • SkądPleszew
  • Imię:Sławek

Napisano 21 wrzesień 2018 - 08:33

Jednej rzeczy nie rozumiem.. Zapodałeś fotkę z połączeniami, na której jest arduino zasilane 3,3v i kwarc 16mhz - no niestety ale taki kwarc jest poza możliwościami katalogowymi atmegi zasilanej napięciem 3,3v.. Nic się nie wiesza, nic się nie blokuje?..


  • 0

#29 maxiiii

maxiiii
  • Modelarz
  • 1506 postów
  • Age: 50
  • SkądSchwerin
  • Imię:Marek

Napisano 22 wrzesień 2018 - 07:04

Na ebaju i ali są wersje arduino na 16MHz i 3,3v. Linka do ali podałem wcześniej. To na takich modułach robię odbiorniki i nigdy nie miałem zwiechy. Być może są to jakieś "lepsze" wersje atmegi.:) 


  • 0

#30 grubypablo

grubypablo
  • Modelarz
  • 2 postów

Napisano 13 czerwiec 2019 - 08:26

Cześć,

Mega temat. Thx maxiiii.

Póki co polutowałem dwa pajączki na biurku, w związku z tym mam kilka łopatologicznych pytań.

instrukcja ;) openLRSng:

Tx:

- Profile to use - są 4 i przycisk "clone setings" do czego służą? 

- Serial Baudrate i Data Rate - jeśli np chciałbym użyć modułów do telemetrii z APM - mavlink z prędkością 57600 to który parametr mam tak ustawić? (w Data Rate 57600 jest experimental !) - do transmisji wykorzystuję serial porty atmegi? (PD1, PD0 w zakładce openLRSng - RX można skonfigurować Port7 - Rx i Port8 - Tx , nie ma opisu na jakich pinach są te porty ale domyślam się że właśnie PD0,1)

 

maxiiii jak zrobiłeś antenę (po 15 cm na żyłę i ekran?)

Pozdrawiam

 

wszystko tu chodzi na 3,3V, czy sygnał pwm dla serw i ESC, albo wejscia do APM na poziomie 3,3v będzie wystarczający?


  • 0

#31 maxiiii

maxiiii
  • Modelarz
  • 1506 postów
  • Age: 50
  • SkądSchwerin
  • Imię:Marek

Napisano 18 czerwiec 2019 - 08:16

Profile służą do ustawienia czterech ustawień nadajnika i odbiornika przełączanych przyciskiem.

Do telemetrii mavlinka najlepszy firmware to gitsly ( https://github.com/gitsly ) Prędkość air ustaw na 19200 a port szeregowy na 57600.

Porty tx i rx są na z łączu serial opisane jako tx i rx :)

Antenki przycinam na 15,5cm. ( fi 1mm).


  • 0

#32 farmaceuta

farmaceuta
  • Modelarz
  • 8 postów
  • Age: 32
  • SkądMielec
  • Imię:Andrzej

Napisano 25 czerwiec 2019 - 17:24

Witam serdecznie

mam pare pytan do Pana Marka i do wszystkich ktorzy moga pomoc mianowicie;

1. czy do modulow (arduino i si4432 np.) moge wgrac oprogramowanie przez openlrsng konfigurator(wybierajac odpowiednie) czy musi to byc przez Arduino ide?

2. rozumiem, zeby miec telemetrie potrzebuje oprogramowania gitsly...ktore konkretnie to pliki? bo troche tego jest..

3. czy telemetrie moge miec na oryginalnych modulach od hobbyking? mianowicie najbardziej interesuje mnie modulTX 100mw(mam 3 sztuki) i 2 po 1 watt.

probowalem zrobic telemetrie wedlug tego opisu z linku.. https://flyingforfun...m/open-lrs.html  wszystko fajnie opisane itp no ale po zgraniu na arduino wywala mi blad dla plytki.. :unsure: z kolei w ostatnim linku od Pana Marka po skopiowaniu kodu dla TX lub RX do arduino ide wywala mi ze nazwy w kodzie nie maja ustalonych zmiennych ...

prosil bym o odpowiedz bo temat mnie zzera.. ;)


  • 0

#33 maxiiii

maxiiii
  • Modelarz
  • 1506 postów
  • Age: 50
  • SkądSchwerin
  • Imię:Marek

Napisano 25 czerwiec 2019 - 18:51

Odp1.

Wszystko robi się z poziomu konfiguratora. Konfiguracja nadajnika, odbiornika oraz flaszowanie atmegi.

odp2.

Gitsly potrzebny jest tylko do mavlinka.

odp3.a

Tak

odp3b

Patrz punkt 1 :)


  • 0

#34 farmaceuta

farmaceuta
  • Modelarz
  • 8 postów
  • Age: 32
  • SkądMielec
  • Imię:Andrzej

Napisano 25 czerwiec 2019 - 19:30

Dziekuje bardzo za ta ekspresowa odpowiedz :)

no wlasnie o mavlinka mi chodzi glownie..chcialbym uzyskac telemetrie z APM.

tylko nie do konca rozumiem jak i co mam wgrac do modulow..z tego co mi sie wydaje to mam pobrac ten plik   https://github.com/g...ng/tree/mavlink

pozniej przeniesc biblioteki do bibliotek w arduino i teoretycznie powinienem miec mozliwosc zaprogramowania TX/RX..pozniej pod konfigurator ustawic baudrate datarate i co tam trzeba i powinno dzialac tak?

jezeli pisze jakies glupoty to przepraszam..dopiero sie wzialem za ten temat ;)


  • 0

#35 maxiiii

maxiiii
  • Modelarz
  • 1506 postów
  • Age: 50
  • SkądSchwerin
  • Imię:Marek

Napisano 25 czerwiec 2019 - 21:08

Nic nie musisz pobierać. Konfigurator od gisly sam pobierze z githuba najnowsze pliki i zainstaluje je na atmedze. Wystarczy za pierwszym razem podać tylko rx wersja 5.


  • 0

#36 farmaceuta

farmaceuta
  • Modelarz
  • 8 postów
  • Age: 32
  • SkądMielec
  • Imię:Andrzej

Napisano 26 czerwiec 2019 - 13:58

Ponownie dzieki za szybka odpowiedz ;)

jeszcze takie pytanko mam..a raczej czy teraz to dobrze zrobilem..

pobralem sobie konfigurator  gitsly  "openLRSng - Configurator - gitsly"  i zainstalowalem zgodnie z instrukcja z tej strony https://github.com/g...ng-configurator teraz to jest "version 3.8.4" (wczesniej mialem "version 3.8.8" z chrome) nastepnie podpiolem TX (na probe) ustawilem odpowiednia wersje modulu i flashowalem...

teraz po  nacisnieciu "connect" u samej gory mam "Module - "OpenLRSng TX (gitsly)"  i  "Transmitter Firmware version - 3.8.5"  i po wejsciu w zakladke "telemetry" mam dodadkowa funkcje "Yes-MAVLink" (bylo 4 opcje teraz jest 5)..

czyli teraz po ustawieniu odpowiednich predkosci w openlrsng+apm+MP powinienem miec ta telemetrie tak? oczywiscie po zaprogramowaniu rowniez RX..

jako ciekawostke dodam ze podczas flashu wyskakiwal mi blad..."STK500 - Timed out, programming failed" no ale po polaczeniu sie pokazuje normalnie konfigurator z wszystkimi danymi sygnaly pwm analizator sygnalu itp...dziwne...

 
 

 


  • 0

#37 maxiiii

maxiiii
  • Modelarz
  • 1506 postów
  • Age: 50
  • SkądSchwerin
  • Imię:Marek

Napisano 26 czerwiec 2019 - 14:14

Czyli poradziłeś sobie z flashem, teraz tylko latać i latać.:)

prędkość serial ustaw na 57600.


  • 0

#38 grubypablo

grubypablo
  • Modelarz
  • 2 postów

Napisano 02 lipiec 2019 - 13:07

testy z dipolami 15,5cm żyła i ekran = 400m bez większych przeszkód pomiędzy modułami. (oryginalny moduł Turnigy tx9 = 800m.) więc coś chyba nie dobrze (zastanawiam się czy da się uszkodzić obwody wejściowe modułu SI lutując transformatorówką? )

Przyporządkowywanie różnych funkcji w "odbiorniku" działa ładnie, ale jeszcze nie udało mi się telemetrii uruchomić. Nie mam wyboru opcji z mavlinkiem więc chyba muszę przeinstalować configuratora? mam 3.8.8

Czy jak zmienie prędkość seriala na 57600 to już z configuratorem powinien łączyć się po tej prędkości? Bo u mnie zawsze 115200 - po resecie generuje komunikat powitalny właśnie na prędkości 115200 (a nie 57600) a w module po stronie modelu "odbiornik" cisza jak makiem zasiał (cokolwiek bym po stronie apki nie wygenerował )


  • 0

#39 maxiiii

maxiiii
  • Modelarz
  • 1506 postów
  • Age: 50
  • SkądSchwerin
  • Imię:Marek

Napisano 02 lipiec 2019 - 13:51

Osobiście nie widzę możliwości polutowania si transformatorówką, zbyt duży grot.

57600 jest prędkością telemetrii a 115200 jest prędkością portu konfiguracyjnego i nie można go zmieniać. Jest ustawiony na stałe.


  • 0

#40 farmaceuta

farmaceuta
  • Modelarz
  • 8 postów
  • Age: 32
  • SkądMielec
  • Imię:Andrzej

Napisano 02 lipiec 2019 - 23:46

Versja 3.8.8 jest "standardowa" wersja...i nie ma mavlinka. Musisz pobrac inna wersje..3.8.4 kilka postow wczesniej podalem link. Pobierasz calosc ze strony i dalej to juz wiadomo..i masz konfigurator z opcja mavlinka + opcja "telemetry packet size" czy cos takiego ustawione domyslnie na 29..i tak chyba ma zostac bo w kilku opisach tak wlasnie podawali.
A co do predkosci to sam sie zastanawiam jak to ma byc...w jednym tutorialu gosc zmienil predkosc na nizsza i niby dzialalo..no ale Ja tego jeszcze nie probowalem dopiero musze upchnac apm do skrzydla bo drugi raz nie zamierzam go gubic...czlowiek glupi to lata bez autopilota z fpv a pozniej biega jak zajaczek po lakach...po prawie trzech tyg. Dobry samarytanin znalazl model i mi podrzucil na moja droge 200m od domu i nie wiem kto to byl ten dobry..a najsmieszniejsze jest to ze caly zestaw prawie rok w szufladzie lezy i sie niechce zalozyc😅


Ps. Telemetria juz sprawdzona przez bluetooth..wszystko smiga i nic u mnie nie trzeba bylo zmieniac. Wystarczylo dodac urzadzenie blue potem wybrac odpowiedni port i polaczyc..dziala na laptopie i telefonie..ale zauwazylem ze jak latalem nad glowa to bylo wiecej pikniec buzzera niz przed uruchomiona telemetria w lrs. Ale to tylko pojedyncze utraty pakietow wiec w praktyce zasieg powinien byc taki sam a wiecej mi nie trzeba.
  • 0


Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych