Jump to content

Problemy z kalibracją (?) quada


squir002
 Share

Recommended Posts

Witam wszystkich bardzo serdecznie!
Jak już wspomniałem w poście powitalnym, przeglądałem to forum dość długo i przeważnie znajdowałem to, czego szukałem. Niestety po długiej walce z quadem nie mam już sił i większość sposobów nie przyniosła rezultatów. Zacznę od konfiguracji:

  • Rama X525 V3
  • KKMulticopter v5.5 (oprogramowanie zflashowane xcopter 4.7)
  • 4 x XXD 2212 KV1000
  • Śmigła 1045
  • ESC jakieś chyba no-name 30A
  • LiPol Zippy 3SP1 5000mah 30C (tak, wiem, że za ciężki ;))
  • Aparatura Turnigy 9x v2

Samą maszynę kupiłem na ebayu. Jest to mój pierwszy model, który ma mi służyć za wprowadzenie do świata wielowirnikowców. Chciałbym się na nim nauczyć latać (jednocześnie nie bojąc się, że przypadkiem zniszczę kupę kasy) i stopniowo budować drugi model, hexa lub octo (ale to w przyszłości). Póki co mam duży problem z kalibracją (? lub być może czymś innym czego nie wiem) maszyny.
Poniżej filmik z wczoraj:
 

https://www.youtube.com/watch?v=WWJ49CRN3H0

(problem widać do mniej więcej 10 sekundy, później już nagranie ustawienia żyroskopu na PCB [które de facto i tak jest teraz inne])

 

Problem prezentuje się następująco... Przy ustawieniu na PCB wszystkich "regulatorów" (nie wiem jak to się nazywa) na 50%, wszystkie silniki startują oddzielnie.

 

Wyczytałem gdzieś, że takie ustawienie wypada najlepiej z testów innych:

  • YAW (75% ish) << (a właśnie, tu nie jestem pewien co oznacza 'ish', więc ustawiłem no tak jak wynikało to z procentów)
  • PITCH (0%) < przy 0% kontroler wchodzi w centrowanie drążków (http://www.kkmulticopter.kr/index.html?modea=manual), u mnie to było ~10%
  • ROLL (45%)

Więc tak też ustawiłem. Wciąż wszystkie silniki są zdesynchronizowane. OK, gdzieś wyczytałem, że należy ustawić trim. Nie wiem czy dobrze zrozumiałem, ale doleciało to do mnie jako ustawienie trymu w odbiorniku (mam rację?). I gdy wreszcie udało mi się to zrobić (doliczając poprawkę dwóch kanałów, które były odwrócone) - znaczy, gdy wreszcie silniki zaczęły startować mniej-więcej razem, to aż strach go poderwać bo już na ziemi zaczyna breakdance'ować. Jak mi się udało go lekko oderwać od ziemi (tak, że ostatnia noga nie dotykała podłoża), to majestatycznie pierdupnął do góry nogami. Ogólnie rzecz biorąc jest niesamowicie niestabilny i niezdecydowany (niczym moja kobieta).

 

Reasumując, albo ja jestem tępy, albo jestem tępy i nie umiem tego ustawić.
 

Kalibrowałem ESC wg tego schematu:

Set Yaw gain pot to zero.
- Put throttle stick to full.
- Power on.
- LED flashes 3 times.(Ready)
- Check a receiver power.
- Wait a few seconds.(In this state, ignore the beeping.)
- LED flashes 3 times.(Start)[Supported in v1.6 or later]
- Wait for motor signal.(Please refer to the manual of ESC.)
- Throttle to zero.
- Wait for motor confirm signal.
- Power off.
- Restore Yaw gain pot.

I niby poszło prawidłowo.

Czytałem też o PIDach ale to podobnież powinno się robić po ustawieniu maszyny.

 

Czy ktoś może doradzić bardzo początkującemu amatorowi? Będę bardzo wdzięczny za wszelką pomoc!

Link to comment
Share on other sites

  • 3 weeks later...
  • 1 month later...

Mam pytanie, w jaki sposób masz ustawione PID'y bo mam podobny problem z x-copterem. Gdy ustawie potencjometry na 50% model unosi się lecz zachwilę gdzieś ucieka i ciężko jest go ustabilizować. Jeśli ustawię potencjometry wg  schematu (YAW 75%, PITCH 0%, ROLL 45%) to nie moę uruchomić sterownika czyli kkmulticopter v5.5.

 

Moja maszyna to:

  • Rama F450
  • KKMultiCopter v5.5 (soft oryginalny)
  • 4 x EMAX CF2822
  • ESC EMAX 25Ax4  4in1
  • LiPol Turnigy 2200mAh 3S 25C
  • Aparatura niestety E-Sky 0406 35MHz (chcę zamówić Turnigy 9x v2, bo obecna potrafi się zakłucić)

Totalnie nie mam pojęcia jak zabrać się do strojenia. W instrukcji, którą udało mi się znalęźć jest tylko opis jak skalibrować żyroskop ale nie znalazłem jak stroić tymi potencjometrami.

Link to comment
Share on other sites

Jeśli ustawię potencjometry wg  schematu (YAW 75%, PITCH 0%, ROLL 45%) to nie moę uruchomić sterownika czyli kkmulticopter v5.5.

 

To znaczy co się dzieje jak je tak ustawisz?

Link to comment
Share on other sites

To znaczy co się dzieje jak je tak ustawisz?

 

Sterownik nie daje się uzbroić. Zapala się tylko niebieska dioda podczas podłączania LiPo i potem cisza. Jeśli natomiast ustawiam wszystko na 50% to mogę go dopiero uruchomić.

Link to comment
Share on other sites

Sterownik nie daje się uzbroić. Zapala się tylko niebieska dioda podczas podłączania LiPo i potem cisza. Jeśli natomiast ustawiam wszystko na 50% to mogę go dopiero uruchomić.

Zmień pitch na ~10-15%, bo u mnie takie to było :) Przypomniało mi się, że jak jest pitch na 0% to płytka wchodzi w stick centering - tutaj więcej: http://www.kkmulticopter.kr/index.html?modea=manual

Link to comment
Share on other sites

Tak podejrzewałem, żu musi w jakiś tryb wchodzić. Może wieczorem przetestuję jak nie będzie wiatru. Dziękuję za podpowiedź, bo w tej chwili to robię większość po omacku. Jeśli masz jakąś dokumentację poza manualem jak ustawiać te potencjometry to będę wdzięczny. W oryginalnym manualu nie znalazłem jak ustawiać czułość żyroskopów.

Link to comment
Share on other sites

Nie martw się, też nie znalazłem jak ustawić ich czułość - to trzeba zrobić samemu pod model :) Będziesz widział po maszynie. Podniesiesz ją a ona się kręci w prawo - więcej yaw, pochyla się do przodu - mniej pitch, leci na lewy bok - więcej roll. Jeżeli jest inaczej to znaczy, że możesz mieć odwrócone osie w żyro, ale to ewentualnie później. :)

Ten obrazek powinien Ci pomóc:
 

quadcopter_x_flight_dynamics_yaw_pitch_r

Link to comment
Share on other sites

Po wielu próbach i połamanych śmigłach powoli zaczyna latać :). Niestety w dalszym ciągu podczas wznoszenia zaczyna samoczynnie lecieć w którąś stronę. W tej chwili potencjometry mam ustawione w następujący sposób: YAW 60%, PITCH 80%, ROLL 80%. Mam wrażenie, że przy tych ustawieniach lata najlepiej lecz nie do końca jest dobrze. Problem stanowi też mój brak doświadczenia w lataniu co spowodowało ucieczkę quadcoptera ale na szczęście udało mi się go odnaleźć :D. Jeśli zna ktoś jakiś symulator do ćwiczeń to będę wdzięczny za informację, najlepiej freeware :)

Link to comment
Share on other sites

Zmieniłem aparaturę na Turnigy 9x i faktycznie nie trymowałem. Zaraz po uniesieniu próbowałem go ustabilizować i wyleciało mi to z głowy. Jutro wieczorem zrobię kolejny test z ostatnim kompletem śmigieł :). Problem stanowi dla mnie lot w kierunku "do siebie" dlatego chciałem potrenować.

Link to comment
Share on other sites

Trenowanie myślałem robić na symulatorze ale znalazłem tylko Aerosim rc, który działa tylko 2 minuty bez oryginalnego konwertera PPM-USB. Zastanawiam się czy nie łatwiej by mi było z płytką MultiWii ponieważ ma akcelerometry. Puki co muszę próbować na tym co mam, tylko najpierw go będę trymował bo faktycznie o tym zapomniałem.

 

Mam jeszcze pytanko, jak długo trzyma Tobie LiPol 5000mAh bo na moim Turnigy 2200mAh 25/35C to jakieś 10 min. max. ?

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.