Jump to content

NAZE32 + NZ GPS


roberts
 Share

Recommended Posts

Witam,

 

czy ktoś z szanownych forumowiczów ujarzmił tytułowy zestaw?

 

Posiadam kontroler NAZE32 i teoretycznie dedykowany do niego "nisko budżetowy" NZ GPS.

Niestety nie udało mi się go uruchomić, choć wydaje się to banalne, przekopałem już chyba cały internet i jest tyle samo "za" co "przeciw" - są tacy co twierdzą, że śmiga to elegancko, a są i tacy, którzy twierdzą, że nie działa i już :)

 

Opiszę krótko sytuację:

- GPS po podłączeniu przez przejściówkę do komputera nadaje komunikaty w systemie NMEA (pomijając czas jaki potrzebuje, żeby złapać fix'a), w programie U Center pokazuje satelity i współrzędne

- NAZE32 jest również sprawne, wykorzystuje w nim 2 UARTy sprzętowe oraz 2 UARTy programowe, tzw. softseriale. Wiem, że kontroler jest sprawny, bo na UART1 mam USB do komunikacji ze światem, na UART2 mam wpięty odbiornik po SBUS'ie, Na pierwszym softserialu mam telemetrię FrSky po Sporcie i wszystko działa.

 

Chciałem wrzucić GPSa na drugiego softseriala, ale ponieważ nie działał to próbowałem go uruchomić na wszystkich dostępnych UART'ach zarówno sprzętowych jak i programowych i przysłowiowa blada d.....

 

Konfigurator Cleanflight na PC jak i firmware kontrolera w najnowszej dostępnej wersji.

 

Może jest jakiś magiczny trick, żeby to zaczęło gadać ze sobą?

Link to comment
Share on other sites

Przerabiałem dosłownie to samo, ale na Flip32 (STM32F1) oraz dokładnie tej samej pastylce NZ GPS. Efekty dokładnie takie same jak Twoje. Pod FTDI działał pięknie, 3D fix złapany szybko (ale za oknem), po podpięciu pod kontroler lotu kupa. Cleanflight/iNav widział urządzenie, ale żadnego fix'a. W trybie passthrough (komenda gpspassthrough z CLI i uCenter, tutaj potwierdzisz czy masz TX/RX odpowiednio wpięte) coś tam widział, ale za słabo na fix. Doczytałem, że potrzebuję konwerter stanu logiki z 5V na 3,3V. Nabyłem, podłączyłem i dokładnie to samo. Ktoś mądry się wypowiadał, że procesor F1 za bardzo "sieje" aby GPS działał na tych kontrolerach - w co szczerze mówiąc nie chce mi się specjalnie wierzyć. Ktoś inny pisał, że Cleanflight i GPS nie za bardzo się lubią - tzn kod teoretycznie wspiera GPS, ale tryby lotu są lekko mówiąc niedopracowane. Zaprzestałem prób, latam bez, a tryby GPS zostawiam sobie na późniejszy czas i inne latajło.

Próbowałem APM i M8N - i widzi GPS, całkiem szybko łapie fix i prawidłowo się odnajduje na mapie -  jednak ta kombinacja chyba nie lubi tricopterów (moja "pierwyja" zabawka), bo w trybie Stabilize nie chce wznieść się w powietrze, a przy Loiter obraca się na prawy bok i twierdzi, że to prawidłowa pozycja. Na dodatek uzbraja/rozbraja się tylko z drążków (a nie z przełącznika), a na rozbrojenie reaguje po kilkunastu sekundach. Zaniechałem prób po przekopaniu kawałka ogródka śmigłami.

 

Ale jeśli ktoś inny ma na to (nomen omen) FIX to też chętnie spróbuję :)

Link to comment
Share on other sites

U mnie problemem jest to, że te 2 układy (naze32 i NZ GPS) w ogóle ze sobą nie chcą gadać, fix - fixem, ale u mnie nawet nie zapala się ikona gps'a w cleanflight, świeci się akcelerometr, żyroskop, magnetometr i barometr, a gps nie. Próbowałem na wszystkich portach, na wszystkich prędkościach oraz na AUTO, zamieniałem TX z RX i nic, autoconfig itp, itd...

 

Znalazłem w sieci pliki wsadowe do konfiguracji pod U center, ładnie się wczytują, gps się przestawia, ale niestety chyba ten model nie ma flash'a ale przynajmniej mój jest zwalony bo nie zapamiętuje ustawień po wyłączeniu zasilania. Tak więc jedyne co mogę to próbować się z nim dogadać na ustawieniach fabrycznych.

 

EDIT:

podłączyłem gps pod sprzętowego uarta2, odpaliłem w CLI serialpassthrough (o dziwo cleanflight w wersji2.02 nie ma komendy gpspassthrough - albo ja jej nie ogarniam) i w CLI lecą dane z gpsa w NMEA, a kontroler tego nie ogarnia :(

Link to comment
Share on other sites

  • 2 months later...

U mnie problemem jest to, że te 2 układy (naze32 i NZ GPS) w ogóle ze sobą nie chcą gadać, fix - fixem, ale u mnie nawet nie zapala się ikona gps'a w cleanflight, świeci się akcelerometr, żyroskop, magnetometr i barometr, a gps nie. Próbowałem na wszystkich portach, na wszystkich prędkościach oraz na AUTO, zamieniałem TX z RX i nic, autoconfig itp, itd...

 

Znalazłem w sieci pliki wsadowe do konfiguracji pod U center, ładnie się wczytują, gps się przestawia, ale niestety chyba ten model nie ma flash'a ale przynajmniej mój jest zwalony bo nie zapamiętuje ustawień po wyłączeniu zasilania. Tak więc jedyne co mogę to próbować się z nim dogadać na ustawieniach fabrycznych.

 

EDIT:

podłączyłem gps pod sprzętowego uarta2, odpaliłem w CLI serialpassthrough (o dziwo cleanflight w wersji2.02 nie ma komendy gpspassthrough - albo ja jej nie ogarniam) i w CLI lecą dane z gpsa w NMEA, a kontroler tego nie ogarnia :(

 

ten GPS nadaje NMEA a INAV dla naze32 ogarnia tylko tryb UBLOX, trzeba zmienić GPSa i bedzie chodzić jak złoto, tego małego gps nie idzie przestawić na ublox , a trzeba zeby wyplówał takie dane jak pokazano tu https://librepilot.atlassian.net/wiki/spaces/LPDOC/pages/5669417/Configure+a+GPS+for+CC3D#ConfigureaGPSforCC3D-Ucenter

Link to comment
Share on other sites

Temat nieaktualny, po pierwsze przesiadłem się z Cleanflight'a na Inav, po drugie zmieniłem fc na SPracing F3, po trzecie zmieniłem gps'a na ublox neo M8N. 

- Inav ma chyba najlepiej dopracowaną obsługą gps'a

- przesiadka z F1 (naze32) na F3 - bez komentarza :)

- GPS NEO M8N - działanie w porównaniu z NZgps powala z nóg - w bloku na biurku bez kombinacji w kilka sekund od startu mam 7-8 satelit i fixa 3d

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.