Jump to content

Pixhawk - jak tymczasowo wyłączyć sprawdzanie GPS ?


jeziorek74
 Share

Recommended Posts

Witam!

 

Sprawa zapewne błaha, ale nie mogę znaleźć odpowiedniej opcji.

 

Chodzi mi o to, że przy każdej zmianie czy przeróbce w samolocie, muszę go wynosić na zewnątrz, żeby złapał sygnał GPS, bo inaczej nie chce się uzbroić i nie działa mi silnik.

Jak mogę "na chwilę" wyłączyć opcję sprawdzania GPS, żebym mógł uruchomić model w domu ? 

Link to comment
Share on other sites

Maciek, ale to co podałeś działa w trybie Copter, a Paweł chyba działa w trybie Plane. Więc nie wiadomo czy zadziała, bo cały ardupilot to jest jedna wielka kupa nieudokumentowanych wyjątków :-) Ale sprawdzić warto.

Link to comment
Share on other sites

 

http://ardupilot.org/copter/docs/prearm_safety_check.html

 

a dokładniej:

 

Disabling the Pre-arm Safety Check

 

Niestety, próbowałem tej opcji i nie działa. Mam co prawda - jak Tomasz napisał - ArduPlane, ale ustawienia są podobne.

U mnie to się nazywa Arm Checks to Peform (bitmask) (ARMING_CHECK).  Wyłączam wszystko, Pixhawk "zapika" i nic się nie zmienia.

Pojawia się napis ARMED na ekranie Flight data i wyświetla się Bad GPS Health i silnik nadal się nie uruchamia. Jak wyniosę z tym ustawieniem model na zewnątrz, to silnik także nie działa.

Chyba pozostanie mi wędrowanie z modelem na dwór. :(

Link to comment
Share on other sites

Próbowałeś wyłączać GeoFence?


Pixhawk jest ok, to tylko Ardupilot jest kupą. Ja latam na Pixhawku ale na custom, więc raczej nie bardzo pomogę.

Link to comment
Share on other sites

Próbowałeś wyłączać GeoFence?

Przyznam szczerze, że dopiero zaczynam zabawę z Pixhawk i jak do tej pory mam zaliczonych tylko kilka lotów z wykorzystaniem trybu stabilize i circle. Nie mam pojęcia jak włączyć czy wyłączyć GeoFence  :blush:

Link to comment
Share on other sites

Racja, w Plane jest podobnie jak w Copter ale są też różnice, nie mogłem o tym napisać bo byłem bez dostępu do sieci.

 

http://ardupilot.org/plane/docs/arming-your-plane.html

 

Tu masz wymienione parametry na które trzeba popatrzeć i się z nimi zapoznać:

 

  • ARMING_REQUIRE: this controls whether an arming step is required. The default is 1, meaning that arming is required before takeoff. If set to 0 then arming is not required (the plane starts off armed).
  • ARMING_CHECK: this controls what checks the autopilot does before arming is allowed. The default is 1, meaning all checks are done. Most users should leave it at 1, as the arming checks are important to ensure the autopilot is ready.
  • ARMING_RUDDER: This parameter allows you to configure rudder based arming/disarming. The default is 1, meaning you are able to arm with right rudder. If you set this to 2 you can also disarm with left rudder. If you set this to 0 then you will only be able to arm/disarm via a ground station

 

a tu jest strona pozwalająca się zaprzyjaźnić z parametrami, jeśli coś nas ciekawi to wyszukiwać na niej np "arming" albo "fence":

 

http://ardupilot.org/plane/docs/parameters.html 

Link to comment
Share on other sites

  • 3 weeks later...

Trochę czasu upłynęło, ale nadal brak rozwiązania.

Wszystkie te opcje sprawdzałem, ale one są tylko i wyłącznie związane z uzbrajaniem Pixhawk i nie mają wpływu na GPS.

Ogólnie, z tego co zrozumiałem przeglądając rózne zagraniczne fora, wnioskuję, że nie da się wyłączyć sprawdzania GPS. Ma to służyć zabezpieczeniu modelu przed ucieczką lub startem modelu bez złapanego fixa GPS. Trochę to dziwne, bo co w sytuacji, gdy chciałbym używać Pixhawka bez GPSa jako drogiego stabilizatora lotu, a nie autopilota ?

A może się mylę i ktoś jednak wyprowadzi mnie z błędu ?

Link to comment
Share on other sites

Nie rozumiem. Z jednej strony piszesz że problem dotyczy "tylko" uzbrajania, a z drugiej że jest ogólniejszy. Oczywiście że można latać bez GPS, wiele razy to robiłem zarówno copterem jak i samolotem. Tyle że w różnych wersjach, a wiele warunków i opcji się zmieniało między wersjami.

 

Ogólnie to zobacz uwagi o lataniu wewnątrz budynków:

 

http://ardupilot.org/copter/docs/indoor-flying.html

 

  • Disable GPS in non-auto** modes - set AHRS_GPS_USE to 0
  • Disable GPS_FAILSAFE
  • Upvote 1
Link to comment
Share on other sites

 

Nie rozumiem. Z jednej strony piszesz że problem dotyczy "tylko" uzbrajania, a z drugiej że jest ogólniejszy. Oczywiście że można latać bez GPS, wiele razy to robiłem zarówno copterem jak i samolotem. Tyle że w różnych wersjach, a wiele warunków i opcji się zmieniało między wersjami.

 

Ogólnie to zobacz uwagi o lataniu wewnątrz budynków:

 

http://ardupilot.org/copter/docs/indoor-flying.html

 

  • Disable GPS in non-auto** modes - set AHRS_GPS_USE to 0
  • Disable GPS_FAILSAFE

 

Sorki. Może faktycznie namieszałem w moich wypowiedziach. 

W skrócie więc o co mi chodzi: Pomimo, tego, że powyłączam wszystkie uzbrajania i sprawdzania GPS (wszystkie, o których wiem) i tak nie mogę uruchomić w domu silnika modelu, bo wyświetla mi się komunikat Bad GPS Health.

Zależy mi na tym, żeby "na chwilę" w domu móc uruchomić silnik w modelu pomimo braku sygnału GPS.

Ale zaznaczam, że może nie wszystko robiłem jak trzeba, bo moja znajomość angielskiego jest dość płytka, więc nie zawsze wszystko rozumiem.

 

Edit:

 

Zastosowałem 

  • Disable GPS in non-auto** modes - set AHRS_GPS_USE to 0

Niestety w mojej wersji MP nie ma opcji 

  • Disable GPS_FAILSAFE

Pomimo wyłączenia  AHRS_GPS_USE nadal mam komunikat Bad GPS Health.

 

 

Link to comment
Share on other sites

A w którym jesteś trybie lotu? Mam nadzieję że w którymś z niewymagających sygnału GPS? (Manual, FBWA, FBWB)?

 

Z całą pewnością da się latać ArduPlane bez GPS, robiłem to wiele razy, i nic nie zmieniałem w konfiguracji. Po prostu nie było odbiornika GPS i tyle. Ale korzystałem z trybów jak wyżej, i oczywiście wyłączyłem warunek sprawdzania GPS przed uzbrojeniem.

Link to comment
Share on other sites

Oczywiście wszystko w trybie manual. 

Mi nawet nie chodzi o latanie. Mam duży model Powerzone'a 2,6m i żeby uruchomić na chwilę silnik, muszę go wynosić na dwór i czekać na fixa GPS.

A to dość problematyczne, bo bawię się trochę pewnym projektem opartym o Arduino i cokolwiek zmienię, to ponowna wyprawa na dwór, żeby sprawdzić efekty.

Spróbuję jeszcze raz w wolnej chwili. GPS mam fizycznie odłączyć, czy wystarczy jak wyłączę opcję AHRS_GPS_USE ?

Link to comment
Share on other sites

 

 

GPS mam fizycznie odłączyć, czy wystarczy jak wyłączę opcję AHRS_GPS_USE ?

 

Próbuj tak i tak, im więcej tym lepiej. 

 

Ale coś mi się wydaje że możesz mieć źle skonfigurowany warunek przed uzbrojeniem. Czy gdy uzbroisz przy ważnej pozycji GPS a potem odłączysz albo zakryjesz odbiornik GPS to silnik ciągle można włączać? Czy ten warunek ustawiłeś unieważniając wszystkie testy? Bo licząc maski bitowe można się pomylić.

 

Czy coś jeszcze pisze na konsoli? A co jest w logach?

 

Można też oczywiście zrobić na arduino symulację GPS, ale lepiej rozwiązać problem.

Link to comment
Share on other sites

Brak czasu, dlatego dopiero teraz piszę.

 

Dzięki Maćku za zaangażowanie. Problem rozwiązany..., a właściwie zastąpiony innym. Temat można zamknąć - napiszę tylko o przyczynach.

 

Sprawcą całego zamieszania okazało się Arduino Nano, którego użyłem do mojego projektu. Na dzisiaj sprawa wygląda tak - przygotowałem płytkę drukowaną, na której mam wkomponowany moduł oświetlenia samolotu wzorowany na http://pfmrc.eu/index.php?/topic/48170-o%C5%9Bwietlenie-lotnicze-modelu/page-3&do=findComment&comment=522108 + plus parę ewentualnych bajerów i rozprowadzone zasilanie modelu. Całość oparta jest o arduino nano.

Kiedy nie wepnę arduino, wszystko działa jak należy; również jest wszystko OK, kiedy podłączę zasilanie do arduino (cały układ jest zasilany oddzielnym pakietem). Problem zaczyna się wtedy, kiedy arduino jest na pokładzie, ale nie jest zasilane. Wtedy mimo uzbrojenia Pixhawk blokuje uruchamianie silnika. Muszę po prostu poszukać zakłóceń i wyeliminować je.

Link to comment
Share on other sites

Czyli w ogóle nie masz zielonego pojęcia, co tam ci te komputery wyprawiają. To źle rokuje. Ja bym się nie odważył latać maszyną, której nie rozumiem.

Link to comment
Share on other sites

Czyli w ogóle nie masz zielonego pojęcia, co tam ci te komputery wyprawiają. To źle rokuje. Ja bym się nie odważył latać maszyną, której nie rozumiem.

No to nie do końca jest tak  :)

W tej konfiguracji jeszcze maszyna nie latała. A co do problemu, to muszę tylko znaleźć źródło zakłóceń i po sprawie, ale to już temat nie na to forum ;)

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.