Jump to content

Problem z utrzymaniem wysokości na ALT HOLD w APM


Skyllancer

Recommended Posts

Witam wszystkich.

 

Pisze do was z prośbą o pomoc. Posiadam drona w konfiguracji :

 

rama reptile 500 v3

4x emax 2216

4x regulator abc power 30a

apm 2.6

GPS ublox 6m + kompas

4x śmigła 10x4,5 carbon 

Akumulator GENS ACE LiPo BASHING 11,1V 5200mAh 40C

Telemetria

Aparatura Flysky i6x

 

Problem polega na tym, że dron w trybie ALT HOLD nie jest w stanie utrzymać wysokości, kiedy lecę w przód. Przeszukałem już cały internet i rozwiązania, które znalazłem nie pomogły. Zamieniałem kolejnością silniki, zamieniałem miejscami regulatory, dawałem gąbkę na barometr, zaklejałem apm taśmą przed słońcem, apm był na płytce antywibracyjnej i bez, wymieniłem APM na nowy ( na nowym to samo się dzieje), zmieniałem śmigła z plastikowych na karbonowe, zmieniłem baterię, przelutowałem wszystko od nowa, zmieniłem maksymalny kąt wychylenia, odpinałem i podpinałem telemetrię sprawdzając czy nie zakłóca, ustawiałem filtr barometru i dalej to samo. Mam nadzieje, że wymieniłem wszystko. Dron lata super, w momencie kiedy włączam ALT_Hold i chce lecieć do przodu, dron wogóle nie trzyma wysokości, po około 20-30 metrach spada z wysokości 10m do praktycznego zera, w tedy się ratuje włączając tryb zwykłej stabilizacji i wyprowadzam go ze spadania na bezpieczną wysokość. Próbowałem go naprawić już z 4 modelarzami ale ręce rozłożyli.

 

Nie jestem wszechwiedzący a bliżej mi chyba już do początkującego jak widzę co się dzieje wiec wszelkie uwagi miło widziane.

 

Błagam pomóżcie :)

 

Pozdrawiam

Link to comment
Share on other sites

Nie rozumiem - czy trzyma wysokość w altHold nie lecąc do przodu? Jaka wersja ArduCoptera?

 

Próbowałeś autotune z trybów najpierw altHold, a potem Loiter?

 

Jaka jest pozycja drążka gazu? Wiesz o tym że w altHold działa on inaczej niż w stabilize? 

Link to comment
Share on other sites

Dron nie trzyma wysokości lecąc w przód, jeśliś stoję w miejscu to jest nie najgorzej chociaż zdarza mu się opadać również stojąc w miejscu. 

 

Wersja arducoptera to 3.5.5 - najnowsza.

 

Próbowałem również robić autotune ale działa on tylko w althold, w loiter niestety wogole nie reaguje. Autotune wogóle się nie włącza w Loiter.

 

Jeśli chodzi o drążek gazu to jest w pozycji środkowej. Tak wiem na czym polegają różnice w trybach lotu.

 

Jak złożyłem drona i wsadziłem apm to przez pierwsze 2-3 dni było wszystko ok, później zaczęły dziać się problemy, dosłownie pomiędzy jednym naładowaniem a drugim. Nie było w tym czasie żadnego kreta.

Link to comment
Share on other sites

Ale czy zapisujesz wyniki autotune? Jest jakaś poprawa/zmiana?

 

Czy problem występuje także przy locie w bok i do tyłu? Jaka jest prędkość pozioma?

 

Dlaczego nie można włączyć autotune w loiter? Czy włączasz za pomocą kanału 7/8, czy przez przełączanie trybów lotu? Jeśli to drugie, to może wyłącza się loiter zanim włączy się AT?

Link to comment
Share on other sites

Tak zapisuje, i po poprawnie wykonanym autotune jest poprawa lotu. Dron jest stabilniejszy i nie oscyluje ale nie ma to wpływu na opadanie w althold, w sensie opada tak samo jak przed autotune.

 

Przy lotach w tył i w bok nie zauważyłem, żeby opadał ale muszę sprawdzić jeszcze na wieszczej odległości.

 

Na trybach lotu mam ustawione tylko, stabilize, althold oraz loter. Na przełącznicach ( ch7/8) mam ustawione RTL oraz Autotune. Telemetrie mam podłączoną do smartfona lub do laptopa. Jak włączam autotune na althold to wyskakuje komunikat o starcie atutune oraz o poprawnym jego zakończeniu. Jak włączam autotunena trybie loter to nic się nie pojawia, wogóle nie reaguje na włączenie autotune.

Link to comment
Share on other sites

Piszesz,że do swojego APM-a wgrałeś najnowszą wersję arducoptera.Dla APM-a przeznaczone są wersje do 3.2.1 .Wgraj tą wersję i powinno wszystko dobrze hulać. Autotune zgodnie z dokumentacją przeprowadza się w trybie Althold.Powodzenia

Link to comment
Share on other sites

Piszesz,że do swojego APM-a wgrałeś najnowszą wersję arducoptera.Dla APM-a przeznaczone są wersje do 3.2.1 .Wgraj tą wersję i powinno wszystko dobrze hulać. Autotune zgodnie z dokumentacją przeprowadza się w trybie Althold.Powodzenia

Jest już wgrana i nie ma potrzeby wgrywać ponownie.

 

 

Jaką wartość ma parametr thr mid ?

Jaką wartość ma  thr out w zawisie?

Link to comment
Share on other sites

Jeśli chodzi o THR_Mid to 500, niestety THR_out nie mogę znaleźć 

 

Rozumiem, że thr out jest w logach, będę musiał wykonać jutro test w alt hold i w tedy będę mógł podać.

 

Okazało się ze wersja arducoptera to 3.2.1, dzisiaj zrobiłem test alt hold ale nie na autotune wiec jak coś to mogę wrzucić logi.

Link to comment
Share on other sites

  • 2 months later...
  • 4 weeks later...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.