Jump to content

Witam pomoc przy PID"ach


Recommended Posts

Witam mam wgrany wsad ,
 

1 lodka zamiast w prosto leko daje na prawo pewnie cos w PID moze ktos podpowiedziec 

1wsad apm2.8.param

odbiornik kanał 1 do input 1
odbiornik kanał 2 do input 3


image.thumb.png.9a4bfc2bb6273c2571334747b25a7cd3.png

image.png.8d30497dff00164be8376a2c473da07b.png

 

take mam pidy

Link to comment
Share on other sites

2 godziny temu, maxiiii napisał:

Spróbuj sterring zmniejszyć o połowę. 

 

E tam.

To by znaczyło, że jak zmniejszysz PID-y to zacznie płynąć prosto, a jak jeszcze bardziej zmniejszysz to zacznie płynąć w lewo. No nie.

PID-y mają wpływ na: szybkość sterowania (szybkość i wielkość reakcji na odchylenie od kursu), odchyłkę sterowania (czy odchylenie zostanie zniwelowane do zera i jak szybko) i dynamikę sterowania (czy będzie niwelował odchylenie asymptotycznie czy będzie przesterowywał i niwelacja odchylenia będzie z malejącymi oscylacjami lewo-prawo, albo może nawet oscylacje będą rosły).

 

Napisz coś więcej o sytuacji i otoczeniu bo to może mieć znaczenie. Czy to jest po prostu płynięcie z puszczonymi starami, czy nawigacja na punkt wg GPS? Czy to jest jezioro czy rzeka z nurtem? Czy spokojnie czy jakiś wiaterek?

Link to comment
Share on other sites

Czy brałeś pod uwagę jakie elementy biorą udział w sterowaniu gdy używany jest tryb manual?

Co chcesz zmieniać w powyższym oknie które dostosowane jest do nowszych autopilotów niż APM? 

Zwróć uwagę na wartość kanału pierwszego. To jest powód skrętu. Zmień tę wartość w aparaturze. 

A co do pidów to lubię zmieniać bo się na nich nie znam.

Link to comment
Share on other sites

1 nie nie znam sie 2 chcial bym zmienic trim na mnejsze lewego silnika   

3 jaka wartos kanalu pierwszego  ?

Czy brałeś pod uwagę jakie elementy biorą udział w sterowaniu gdy używany jest tryb manual?
wlasnie nie wiem 

 

 

Link to comment
Share on other sites

W manualu bierze udział aparatura, regulatory i silniki. apm przepuszcza sygnał bez ingerencji w niego. Zmień trim w aparaturze na 1500. Powinno być dobrze. Należy wtedy ponownie kalibrować aparaturę w apemie. Inne tryby mogą działać wtedy nieprawidłowo.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.