Jump to content
AKocjan

Spitfire RC - chwilowa utrata kontroli nad modelem

Recommended Posts

2 godziny temu, jarek_aviatik napisał:

Jak na razie to są dywagacje ludzi, którzy chcą nazwijmy to pomóc.

Oczywiście. odnoszę sie do faktu istnienia znanego baga. FRysky oficjalnie się do niego przyznaje.

2 godziny temu, poharatek napisał:

Robert mieszasz dwie rzeczy: otwarte oprogramowanie nadajnika nie ma nic wspólnego z protokołem transmisji między nadajnikiem a odbiornikiem.

Nie sądzę. Ma bardzo dużo wspólnego z protokołem transmisji. Transmisje obsługuje jakis drajwer prawda w systemie a każdy protokoł transmisji ma obsługę blędów.

Samo oprogramowanie i firmware jest robiony przez tego samego dostawcę, więc jak tu jest coś nie tak na styku to pijarowo nie wygląda to dobrze.

Share this post


Link to post
Share on other sites
Godzinę temu, maxiiii napisał:

Nie widzę powodu do przenoszenia ze względu na to, że nic nie wiemy o przyczynie takiego zachowania. Oprócz źle ustawionej aparatury podejrzewam jeszcze spadek napięcia na odbiorniku czyli o błędnej instalacji w modelu. Odbiornik przy chwilowym spadku napięcia może zacząć wariować i dawać złe sygnały. 

Zacząłbym od sprawdzenia aparatury bo jest to najprostsza sprawa którą można zrobić pijąc kawę i oglądając tvn. :)

to raz.

Dwa to sprawdziłbym ustawienia FS a dopiero potem całą instalację. Potem krótki spacerek z modelem w ręku i sprawdzenie czy sytuacja się powtórzy.

Ale teraz trzeba czekać na reakcję założyciela tematu bo czuję, że temat przerodzi się w dyskusję który system jest lepszy i bardziej odporny na zakłócenia a zarazem droższy. :)

mam jeszcze podejrzenia odnośnie utraty sygnału sterującego serwomechanizmami, bo w domu po locie udało mi się podobny efekt uzyskać - lotki zostały zablokowane na maksymalnym wychyleniu. Ogólnie przez tą niebieską kostkę w razie wypięcia przewodu z kanału lotek (odbiornika), zasilanie podawane  od kanałów dla klap i podwozia nadal jest na wyjściu do serw lotek, a sygnału sterującego brak. Nie wiem czy to jakieś przemyślane zabezpieczenie, w każdym razie raz na 10 wypięć kabla lotki się blokowały na na maksymalnym wychyleniu.  Dlatego planuję w pierwszej kolejności wypiąć  lotki z tej kostki i przeprogramować model (lotki na dwa kanały). Ustawię sobie dzięki temu dodatkowo różnicowe wychylenie lotek. Następnie trzeba będzie się dalej zastanowić nad aparaturą, jutro prześlę informację odnośnie radia. 

Share this post


Link to post
Share on other sites
11 minut temu, robertus napisał:

Oczywiście. odnoszę sie do faktu istnienia znanego baga. FRysky oficjalnie się do niego przyznaje.

Nie sądzę. Ma bardzo dużo wspólnego z protokołem transmisji. Transmisje obsługuje jakis drajwer prawda w systemie a każdy protokoł transmisji ma obsługę blędów.

Samo oprogramowanie i firmware jest robiony przez tego samego dostawcę, więc jak tu jest coś nie tak na styku to pijarowo nie wygląda to dobrze.

Robert, za przeproszeniem: pitolisz trzy po trzy...

OpenTx jest  otwartym (open source) firmware do nadajników, tworzonym przez społeczność użytkowników. Da się go zainstalować nie tylko na nadajnikach FrSky (tu masz listę: https://www.open-tx.org/radios). Z FrSky jest o tyle związane, że da się je zainstalować na każdym nadajniku tej firmy, a niektóre (np. Taranis, Q7 ), mają je zainstalowane fabrycznie, ale inne, np. seria Horus przychodzi z preinstalowanym autorskim FrOS.

Inna bajka jest  jeśli chodzi o firmware modułu nadawczego,  odbiorników, czujników telemetrii itd., bo są one autorskimi rozwiązaniami firmy FrSky i jako takie nie mają nic wspólnego z open source.

Podobnie systemy transmisji pomiędzy nadajnikiem a odbiornikiem (ACCST, ACCES) - to również wytwór FrSky i bynajmniej nie są otwarte. 

Share this post


Link to post
Share on other sites

Robert Marcin ma rację sposób przesyłania sygnału pomiędzy modułem nadawczym a odbiornikiem nie ma nic wspólnego z rodzajem sygnału wejściowego wychodzącego z aparatury.

https://oscarliang.com/pwm-ppm-sbus-dsm2-dsmx-sumd-difference/

 

Godzinę temu, AKocjan napisał:

Ogólnie przez tą niebieską kostkę

Proponuję wymienić na czerwoną. Wiadomo czerwone jest szybsze. 

A tak na serio to z twojego opisu może wynikać problem z zasilaniem. To, że robisz źle wpinając te wtyczki pod napięciem to już nie będę pisał ( to takie hardcorowe) :)

Istnieje możliwość, że w pewnych sytuacjach pod większym obciążeniem brakuje prądu dla odbiornika i tez zaczyna szaleć. 

Podaj jak masz zasilane serwa, odbiornik i skąd bierzesz do tego wszystkiego prąd.

 

  • Upvote 1

Share this post


Link to post
Share on other sites

Dobra, może się źle wyraziłem. Piszę to na podstawie tego co czytałem. Czytałem, że Frysky mocno angażuje się w społeczność i dofinansowuje jej rozwój.

Czytałem też, że Frysky zamierza w niedługim czasie zamknąć oprogramowanie albo jakąś jej kompilację, którą będzie rozwijać samemu a nie jako open.

Stąd dla mnie opentx to dziecko Frysky. Nie wiem, mylę się?

Share this post


Link to post
Share on other sites
12 godzin temu, robertus napisał:

Dobra, może się źle wyraziłem. Piszę to na podstawie tego co czytałem. Czytałem, że Frysky mocno angażuje się w społeczność i dofinansowuje jej rozwój.

Czytałem też, że Frysky zamierza w niedługim czasie zamknąć oprogramowanie albo jakąś jej kompilację, którą będzie rozwijać samemu a nie jako open.

Stąd dla mnie opentx to dziecko Frysky. Nie wiem, mylę się?

To też nie tak.

Ogólnie, jest całkiem sporo "otwartego" oprogramowania RC, zarówno jeśli chodzi o firmware nadajników, jak i open source  protokoły transmisji (np. openLRS), ile tego jest, można zobaczyć tu: https://openrcforums.com/forum/index.php.

Historycznie, pierwszym otwartym firmware nadajników było Er9X do nadajników Turnigy i FlySky. 

OpenTx jest "forkiem" (odgałęzieniem) tego firmware, głównie dla nadajników od FrSky i odziedziczyło po nim większość rozwiązań. Fakt, jego powstanie i szybki rozwój wynikało ze ścisłej współpracy między firmą FrSky a społecznością, ale bynajmniej nie można napisać, że jest ono "dzieckiem" FrSky (to określenie jest prawdziwe tylko w stosunku do FrOS).

Faktem jest również, że ostatnio ta współpraca nieco się popsuła a FrSky zaczęło wykonywać jakieś dziwne kroki, którymi solidnie wkurzyło społeczność zgromadzoną wokół OpenTx. Ale nawet gdyby FrSky zdecydowało się na potężny "strzał w stopę" i  "zamknęło" całkowicie oprogramowanie dla swoich nadajników, dla społeczności niewiele to zmienia, a inni producenci (Jumper np.) już przebierają nogami, żeby ją przygarnąć ;)

Share this post


Link to post
Share on other sites

@maxiiii  zasilanie  z regulatora wyposażonego w BEC'a: https://www.motionrc.eu/products/freewing-80mm-edf-80a-brushless-esc 
Myśli Pan , że z tym może być problem?  Spadki napięć? Sprawdzałem regulator, nigdy żadnych spadków nie zaobserwowałem mimo pełnego obciążenia. Ewentualnie można wstawić kondensatory równolegle ? 

to ten dziwny rozdzielacz sygnału (na wejściu bezpośrednio z odbiornika (kanał lotek; klap; podwozia)
na wyjściu sygnał jest przekazywany na prawe / lewe skrzydło.

20200223_130203[1].jpg

20200229_111208[1].jpg

Share this post


Link to post
Share on other sites

Czy regulator się nie grzeje ?

 

 W  przypadku przegrzania stabilizatorów     bec może być na chwilę wyłączany do wystygnięcia.  Samo ewentualne przegrzanie niekoniecznie musi wynikać z poboru prądu przez serwa -czasem stabilizator podgrzewany jest przez tranzystory mocy znajdujące się obok.

Z objawów -że problem tylko jeden kanał i tylko sekunda czy dwie  bardziej obstawiałbym problem z softem -lub zły kontakt na którejś wtyczce lub zimny lut w tym niebieskim pudełeczku...

  • Upvote 1

Share this post


Link to post
Share on other sites

Z niebieskiego pudełka usuwam lotki i rozdzielam na dwa kanały, ale boję się jeszcze właśnie o softa (nie było komunikatu o utracie zasięgu, więc zasilanie  było)

Share this post


Link to post
Share on other sites

z utratą zasięgu i komunikatem...

Nie wiem jak u Ciebie  (inny system)  

 

     -u mnie (hitec aurora 9, optima 7, optima 9 + moduły i czujniki  telemetrii) ) jeśli gwałtownie  spadnie napięcie  odbiornika     (lub na moment przerwa w zasilaniu)  to nie ma żadnych komunikatów. Jest wyświetlany ostatni komunikat gdy jeszcze było OK.

 

-Odbiornik wysyła paczki info o stanie telemetrii -gdy coś się zmienia -idzie kolejna informacja np z ostrzeżeniem.  Ale jeśli z jakiegoś powodu jest gwałtowne zerwanie linku np utrata zasilania lub spadek napięcia odbiornika poniżej 3,5V, przelecenie za drzewem czy krzakiem   -to nie ma info o awarii i nadajnik wyświetla ciągle ostatnio otrzymaną jeszcze prawidłowa  informację  -po chwili system ponownie się binduje i sygnał jest znowu prawidłowy.  Po prostu zanim odbiornik wyśle info, że coś nie tak -to już nic nie może wysłać -a potem ma kolejne info, że już jest OK.  oczywiście, gdy np. spadek napięcia jest wolniejszy -to uwidacznia to telemetria, generuje alarmy itp.

 

Nie wiem jak jest w Twoim systemie -ale " mechanizm"  wymiany informacji  może być podobny -może maskować gwałtowne krótkotrwałe zerwanie łączności.

Share this post


Link to post
Share on other sites
2 godziny temu, latacz napisał:

z utratą zasięgu i komunikatem...

Nie wiem jak u Ciebie  (inny system)  

 

     -u mnie (hitec aurora 9, optima 7, optima 9 + moduły i czujniki  telemetrii) ) jeśli gwałtownie  spadnie napięcie  odbiornika     (lub na moment przerwa w zasilaniu)  to nie ma żadnych komunikatów. Jest wyświetlany ostatni komunikat gdy jeszcze było OK.

 

-Odbiornik wysyła paczki info o stanie telemetrii -gdy coś się zmienia -idzie kolejna informacja np z ostrzeżeniem.  Ale jeśli z jakiegoś powodu jest gwałtowne zerwanie linku np utrata zasilania lub spadek napięcia odbiornika poniżej 3,5V, przelecenie za drzewem czy krzakiem   -to nie ma info o awarii i nadajnik wyświetla ciągle ostatnio otrzymaną jeszcze prawidłowa  informację  -po chwili system ponownie się binduje i sygnał jest znowu prawidłowy.  Po prostu zanim odbiornik wyśle info, że coś nie tak -to już nic nie może wysłać -a potem ma kolejne info, że już jest OK.  oczywiście, gdy np. spadek napięcia jest wolniejszy -to uwidacznia to telemetria, generuje alarmy itp.

 

Nie wiem jak jest w Twoim systemie -ale " mechanizm"  wymiany informacji  może być podobny -może maskować gwałtowne krótkotrwałe zerwanie łączności.


ja zawsze dostanę informacje o utracie telemetrii od nadajnika, który nie otrzymuje informacji zwrotnej. Jeżeli poleci tylko sensor (np wysokościomierz - jest tylko informacja o jego utracie). No i na bieżąco jest monitorowana siła sygnału. 

Share this post


Link to post
Share on other sites

pytanie  -czy rzeczywiście  otrzymujesz info, że nadajnik nie dostał informacji zwrotnej -nawet jeśli zanik jest ułamek sekundy ? czy system  nie maskuje krótkich zakłóceń ?

 

     spróbuj może zweryfikować praktycznie     -wyłącz     na sekundę (lub krócej)  zasilanie odbiornika - i sprawdź czy nadajnik  sygnalizuje utratę łączności ? powtórz to  kilka x czy zawsze sygnalizuje - czy nie maskuje krótkiego problemu gdy odbiornik nagle przestaje działać na sekundę ? Czy w chwili włączenia zasilania modelu serwa stoją (zwłaszcza te problematyczne lotki) -czy wykonują szybkie machnięcie ?

 

 

takie uciekanie NIEKTÓRYCH serw na moment występuje  gdy albo brak sygnału albo "migniecie" zasilania -niekoniecznie musi być błędny sygnał. Może coś nie kontaktuje -albo same serwa są wrażliwe na zakłócenia ?

Miewałem takie problemy -machnięcia/wychylenia  kiepskich  serw (np.TP 90s) w chwili gdy odpalałem silnik -dodawałem gwałtownie gazu w napędach o bardzo niskiej oporności (i nie był to spadek napięcia -tylko zakłócenie)

 

Share this post


Link to post
Share on other sites
14 minut temu, latacz napisał:

pytanie  -czy rzeczywiście  otrzymujesz info, że nadajnik nie dostał informacji zwrotnej -nawet jeśli zanik jest ułamek sekundy ? czy system  nie maskuje krótkich zakłóceń ?

 

     spróbuj może zweryfikować praktycznie     -wyłącz     na sekundę (lub krócej)  zasilanie odbiornika - i sprawdź czy nadajnik  sygnalizuje utratę łączności ? powtórz to  kilka x czy zawsze sygnalizuje - czy nie maskuje krótkiego problemu gdy odbiornik nagle przestaje działać na sekundę ? Czy w chwili włączenia zasilania modelu serwa stoją (zwłaszcza te problematyczne lotki) -czy wykonują szybkie machnięcie ?

 

 

takie uciekanie NIEKTÓRYCH serw na moment występuje  gdy albo brak sygnału albo "migniecie" zasilania -niekoniecznie musi być błędny sygnał. Może coś nie kontaktuje -albo same serwa są wrażliwe na zakłócenia ?

Miewałem takie problemy -machnięcia/wychylenia  kiepskich  serw (np.TP 90s) w chwili gdy odpalałem silnik -dodawałem gwałtownie gazu w napędach o bardzo niskiej oporności (i nie był to spadek napięcia -tylko zakłócenie)

 

jak rozłączam zasilanie mam zawsze komunikat o utracie telemetrii, radio nie dostaje danych - informuje, robi to nawet, kiedy przerwa trwa krótko

 

Share this post


Link to post
Share on other sites

Na RCGroups można znależć wiele negatywnych komentarzy dotyczących tych blue-box-ów. Użytkownicy zalecają ich usunięcie, a przynajniej ograniczenie ich stosowania do mniej ważnych funkcji, jak składane podwozie i oświetlenie, na przykład tutaj https://www.rcgroups.com/forums/showthread.php?3128905-Freewing-L-39-Albatros-80mm-EDF/page179#post42423727 albo tutaj https://www.rcgroups.com/forums/showthread.php?3166439-Freewing-Blue-box-MCB-E-good-Bad-ugly#post40536905

Wiktor

  • Upvote 1

Share this post


Link to post
Share on other sites
13 godzin temu, wiktoreksz napisał:

Na RCGroups można znależć wiele negatywnych komentarzy dotyczących tych blue-box-ów. Użytkownicy zalecają ich usunięcie, a przynajniej ograniczenie ich stosowania do mniej ważnych funkcji, jak składane podwozie i oświetlenie, na przykład tutaj https://www.rcgroups.com/forums/showthread.php?3128905-Freewing-L-39-Albatros-80mm-EDF/page179#post42423727 albo tutaj https://www.rcgroups.com/forums/showthread.php?3166439-Freewing-Blue-box-MCB-E-good-Bad-ugly#post40536905

Wiktor

dziękuję 

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.