Jump to content
AKocjan

Spitfire RC - chwilowa utrata kontroli nad modelem

Recommended Posts

W dniu 23.02.2020 o 19:26, AKocjan napisał:

Co prawda model finalnie nie spadł, ale niewiele brakowało, zresztą problem wystąpił pechowo kiedy akurat nos modelu był ustawiony w moją stronę.

 

Jeżeli antenki były ułożone wzdłuż kadłuba i sygnał został zasłonięty przez silnik to łączność mogła zostać przerwana.

Share this post


Link to post
Share on other sites

 

36 minut temu, stema napisał:

 

Jeżeli antenki były ułożone wzdłuż kadłuba i sygnał został zasłonięty przez silnik to łączność mogła zostać przerwana.

Dodam do tego celowanie anteną w model i sytuacja gotowa. 1:100 ale możliwa moim zdaniem.

Share this post


Link to post
Share on other sites
Guest
2 godziny temu, robertus napisał:

Takie rzeczy to chyba tylko w Taranisie?

Ale gdzieś w otchłani internetu wspominał, że ma Taranisa?

Nie wspomnę o filmikach, w których... a nie, to nie ten temat

 

taranis.JPG

Share this post


Link to post
Share on other sites

Sprawdzenie w normalnym trybie zajmuje max 0,5 godz. łącznie ze spacerkiem ale........

Share this post


Link to post
Share on other sites
W dniu 26.02.2020 o 19:33, maxiiii napisał:

Tutaj jest to obszernie podane.

http://www.sgm.siedlce.pl/index.php/warsztat/narzedzia/437-arduinoppm

 

A tak w skrócie to każdy kanał zajmuje czas. Czym więcej kanałów tym suma tych czasów jest większa. Ramka to ustalony czas na wszystkie kanały. Jeżeli jest za krótka to jakieś kanały nie są sczytywane. Jeden kanał to max 2200us. Standardowa ramka wynosi 22,5ms dla 8 kanałów( z małym zapasem). Dla 16 kanałów czas nie może być mniejszy niż 36 ms a najlepiej 42ms.  Minimalna ramka dla 8 kanałów wynosi 8 x 1000us = 8000us ale wtedy każdy ruch drążka nie zostanie odczytany. max wynosi wtedy 8 x 2200 = 17600 us. 

Proste. :)

ja mam odbiornik na 8 kanałów z tego co kojarzę, aparatura pewnie na 16, pytanie brzmi cz to ograniczyłem

 

5 godzin temu, stema napisał:

 

Jeżeli antenki były ułożone wzdłuż kadłuba i sygnał został zasłonięty przez silnik to łączność mogła zostać przerwana.

mam telemetrię, nie było komunikatu o utracie sygnału, poza tym wydaje mnie się, że miałem kontrolę nad sterem wysokości 

Share this post


Link to post
Share on other sites

Wygląda na to, że dotknął Cię problem opisany np. tu: https://translate.google.com/translate?sl=auto&tl=en&u=https%3A%2F%2Ffrsky-forum.de%2Fthread%2F3404-historie-und-zusammenfassung-der-wichtigsten-informationen-zum-thema-pl%C3%B6tzliche%2F , czyli błąd w firmware modułu nadawczego i odbiorników, który objawia się tym, że sporadycznie może dojść do samoczynnego wychylenia serw podpiętych na niektórych kanałach.

Rozwiązaniem jest aktualizacja firmware FrSky ACCST D16 do wersji v.2, tu jest opisane co i jak: https://77hobby.pl/wazne-uaktualnienie-firmware-frsky-accst-d16-v2-n-51.html

 

Swoją drogą muszę zwrócić @mak honor, bo upierałem się w tym wątku https://pfmrc.eu/topic/83304-frsky-accst-d16-v2/, że uaktualnienie służy jedynie "zamknięciu" protokołu ACCST , a wychodzi na to, że faktycznie rozwiązuje realny problem i trzeba będzie to zrobić u siebie (na 8 odbiornikach... niektórych mocno zabudowanych w modelu.. ech.... ;) )

Share this post


Link to post
Share on other sites
9 godzin temu, AKocjan napisał:

ja mam odbiornik na 8 kanałów z tego co kojarzę, aparatura pewnie na 16, pytanie brzmi cz to ograniczyłem

Hmm, 

Używam Taranisa, tu ważne jest aby przestrzegać instrukcji bindowania  - jeśli jest zrobiona nieprawidłowo, dzieją się różne rzeczy dziwne.

Każdy odbiornik ma odpowiednie wymagania do bindowania.

Czy latasz na odbiornikach FrSky czy inne są zbindowane? To też ważne.

Usuwanie usterek, zawsze zaczyna się od rzeczy najprostszych, i nie wszystko na raz, gdyż po zniknięciu usterki nie wiadomo co pomogło.

 

Wyjątek w moim postanowieniu.

Share this post


Link to post
Share on other sites
6 godzin temu, poharatek napisał:

czyli błąd w firmware modułu nadawczego i odbiorników, który objawia się tym, że sporadycznie może dojść do samoczynnego wychylenia serw podpiętych na niektórych kanałach.

 

 

Fajny darmowy bajer :D Na pewno może podnieść znacząco ciśnienie nawet przy spokojnym lataniu u bardzo spokojnego modelarza :) A zarazem obudzić czy wyrwać z letargu

Share this post


Link to post
Share on other sites
11 minut temu, cZyNo napisał:

 

Fajny darmowy bajer :D Na pewno może podnieść znacząco ciśnienie nawet przy spokojnym lataniu u bardzo spokojnego modelarza :) A zarazem obudzić czy wyrwać z letargu

Ano: od relaksu przy np. leniwym szukaniu noszenia, po zawał serca :D Taki "ficzer", żeby za spokojnie nie było ;) 

A bardziej serio, w czasie kilkuset godzin wylatanych na Taranisie - nie zaobserwowałem tego. Ale skoro u Arka się tak dzieje, no to jednak coś na rzeczy jest....

 

Share this post


Link to post
Share on other sites

Zajebiscie. Cieszę się zatem że mam zwykłą aparaturę z zamkniętym softem. Może mam mniej możliwości oprogramowania ale przynajmniej stresu też mniej.

 

To powinno pojawić się w wątku o Taranisie ku przestrodze.

 

 

Share this post


Link to post
Share on other sites
21 minut temu, robertus napisał:

Zajebiscie. Cieszę się zatem że mam zwykłą aparaturę z zamkniętym softem. Może mam mniej możliwości oprogramowania ale przynajmniej stresu też mniej.

 

To powinno pojawić się w wątku o Taranisie ku przestrodze.

Jak na razie to są dywagacje ludzi, którzy chcą nazwijmy to pomóc.

Sam zainteresowany chyba nie wie jak odpowiedzieć na niektóre pytania.

Mam taranisa - nie wylatałem kilkuset godzin na min, ale kiladziesiąt - nie było czegoś takiego. Ale jako noga z elektroniki i pochodnych postępuję jak napisano w instrukcjach.

Share this post


Link to post
Share on other sites
34 minuty temu, robertus napisał:

Zajebiscie. Cieszę się zatem że mam zwykłą aparaturę z zamkniętym softem. Może mam mniej możliwości oprogramowania ale przynajmniej stresu też mniej.

 

To powinno pojawić się w wątku o Taranisie ku przestrodze.

 

 

Robert mieszasz dwie rzeczy: otwarte oprogramowanie nadajnika nie ma nic wspólnego z protokołem transmisji między nadajnikiem a odbiornikiem.

(To tak, jakbyś winił np. Windows za zwiechy spowodowane błędami w protokole transmisji USB).

Fakt, że ja trochę nieprecyzyjnie w swoim poście to określiłem - bo błędy wykryto właśnie w protokole transmisji, a zmiana firmware modułu nadawczego i odbiorników spowoduje, że będą się komunikować w nowym, poprawionym ACCST D16 v2.

 

Swoją drogą uważasz, że używany przez Ciebie AFHDS jest w 100% bezpieczny i pozbawiony błędów?

 

Share this post


Link to post
Share on other sites
6 godzin temu, jarek_aviatik napisał:

 

Wyjątek w moim postanowieniu.

Bardzo chętnie pomogę Ci by Twoje postanowienie było wiarygodne i wyjątki się nie powtarzały ...

Wyczerpałeś formułę w tematach AKocjana i zadeklarowałeś że nie będziesz zabierał głosu . Zwrócę szczególną uwagę na Twoje postanowienie. Pisałeś ostro, bawimy się też ostro. Każdy kolejny Twój post będzie kasowany/ukryty/usunięty z tematów AKocjana :)

 

 

Share this post


Link to post
Share on other sites
5 minut temu, Shock napisał:

Bardzo chętnie pomogę Ci by Twoje postanowienie było wiarygodne i wyjątki się nie powtarzały ...

Wyczerpałeś formułę w tematach AKocjana i zadeklarowałeś że nie będziesz zabierał głosu . Zwrócę szczególną uwagę na Twoje postanowienie. Pisałeś ostro, bawimy się też ostro. Każdy kolejny Twój post będzie kasowany/ukryty/usunięty z tematów AKocjana :)

OK - nie ma sprawy, mogę skasować sam moje wpisy, abyś nie miał zbyt wiele pracy, napisz tylko które.

Share this post


Link to post
Share on other sites

Nic nie musisz kasować, jest ok :)

Po prostu nie pisz w nich zgodnie ze swoją deklaracją .

 

Share this post


Link to post
Share on other sites

Tak jak sugeruje Robert, warto aby treść dyskusji pojawiła się w wątku o Taranisie.
Natomiast czytając wpis Arka na początku jakoś specjalnie nie przywiązywałem do tego wagi.
Po wpisie Marcina cyt: Wygląda na to, że dotknął Cię problem opisany np. tu  https://translate.google.com/translate?sl=auto&tl=en&u=https%3A%2F%2Ffrsky-forum.de%2Fthread%2F3404-historie-und-zusammenfassung-der-wichtigsten-informationen-zum-thema-pl%C3%B6tzliche%2F

Skojarzyłem pewną podobną sytuację która mi się przydarzyła, co prawda bardzo dawno temu, mianowicie brak reakcji lotek. Być może to zbieg okoliczności, na szczęście nic się złego nie stało.

Nie sądzę aby powodem była utrata zasięgu. 

 

Share this post


Link to post
Share on other sites

Dziękuję bardzo za zainteresowanie tematem, niestety obecnie nie mogłem sprawdzić parametrów, o które mnie pytano (nie mam dostępu do radia / oprogramowania - byłem poza domem). Będę mieć go dopiero jutro, więc sprawdzę dokładnie. W każdym razie nie będzie to problem z zasięgiem, ponieważ telemetria na nic takiego nie wskazała (brak komunikatów o utracie zasięgu). Pozostałe stery chyba działały jak trzeba. Nie jestem znawcą elektroniki modelarskiej, zawsze ustawiałem wszystko według instrukcji nie wchodząc w szczegóły. Nie było z tym większych problemów. Czytając wpisy kolegów, widzę że warto jednak zagłębić się bardziej w temat, żeby zażegnać problem. Przy QX-7 nie miałem takich historii, ciekawe czy ja czegoś nie namieszałem w ustawieniach. W każdym razie mam uziemionego Spita oraz F-4 do wyjaśnienia zagadki, reszta modeli lata na starszej aparaturze QX-7. Jutro podam informację, dziękuję jeszcze raz 

 

Share this post


Link to post
Share on other sites
17 minut temu, Shock napisał:

Nic nie musisz kasować, jest ok :)

Po prostu nie pisz w nich zgodnie ze swoją deklaracją .

 

Cytuje siebie: "Aby nie być gołosłownym - to już naprawdę ostatni mój wpis w dyskusji z Tobą."

Czyli bezpośrednio z AKocjanem - logika.

OK, zabraniasz w ogóle pisania w wątkach AKocjana (czyli jakaś kara jest) - no cóż jak powiedział klasyk "na władzę nie poradzę" - już nie będę. ?

Share this post


Link to post
Share on other sites

Nie widzę powodu do przenoszenia ze względu na to, że nic nie wiemy o przyczynie takiego zachowania. Oprócz źle ustawionej aparatury podejrzewam jeszcze spadek napięcia na odbiorniku czyli o błędnej instalacji w modelu. Odbiornik przy chwilowym spadku napięcia może zacząć wariować i dawać złe sygnały. 

Zacząłbym od sprawdzenia aparatury bo jest to najprostsza sprawa którą można zrobić pijąc kawę i oglądając tvn. :)

to raz.

Dwa to sprawdziłbym ustawienia FS a dopiero potem całą instalację. Potem krótki spacerek z modelem w ręku i sprawdzenie czy sytuacja się powtórzy.

Ale teraz trzeba czekać na reakcję założyciela tematu bo czuję, że temat przerodzi się w dyskusję który system jest lepszy i bardziej odporny na zakłócenia a zarazem droższy. :)

Share this post


Link to post
Share on other sites

Z racji tego że zawsze podłączam lotki na osobnych kanałach, więc lot nie był tak spektakularny jak w przypadku Spit....a
Gdzie Arek miał lotki na jednym kanale i wykonał ,,piękny,, obrót wokół osi. 

Dodam że zdarzyło mi się to tylko raz, więc może tak jak wspomniałem zbieg okoliczności.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.